ixp4xx: Add back support for Iomega NAS100D
authorLinus Walleij <linus.walleij@linaro.org>
Mon, 20 May 2024 19:32:55 +0000 (21:32 +0200)
committerLinus Walleij <linus.walleij@linaro.org>
Sat, 25 May 2024 07:16:45 +0000 (09:16 +0200)
OpenWrt supported the Iomega NAS100D in the past and it has
64 MB of RAM so if booted from a harddrive it will probably
work just fine. The APEX boot loader already has a build
variant for this machine that we can just pick up and use.

This device has a single ethernet port so bring this online
with DHCP as expected for a NAS device.

Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
target/linux/ixp4xx/base-files/etc/board.d/02_network
target/linux/ixp4xx/image/Makefile

index 864328d6bcf19f71e5a9bedd4d4196773ad15ad7..96d7b31282c278e7b800304e1d0a8e3ce72a8141 100644 (file)
@@ -8,6 +8,7 @@ gateworks,gw2348|\
 gateworks,gw2358)
        ucidef_set_interfaces_lan_wan "eth0" "eth1"
        ;;
+iom,nas-100d|\
 linksys,nslu2)
        ucidef_set_interface_lan "eth0" "dhcp"
        ;;
index b532bcd914d90a828e70f153c21867ce6a9dd29e..14d74cfb7017729c2345fcd3736438240ea92a9a 100644 (file)
@@ -60,6 +60,19 @@ define Device/gateworks_cambria
 endef
 TARGET_DEVICES += gateworks_cambria
 
+define Device/iomega_nas100d
+       DEVICE_VENDOR := Iomega
+       DEVICE_MODEL := NAS100d
+       # USB2 is compiled in and needs no package
+       DEVICE_PACKAGES := ixp4xx-microcode-ethernet kmod-rtc-pcf8563
+       DEVICE_DTS := intel-ixp42x-iomega-nas100d
+       KERNEL := kernel-bin | append-dtb
+       IMAGES := factory.bin
+       # This has to boot from harddisk so just append the kernel
+       IMAGE/factory.bin := append-kernel | linksys-ixp425-image "nas100d"
+endef
+TARGET_DEVICES += iomega_nas100d
+
 define Device/linksys_nslu2
        DEVICE_VENDOR := Linksys
        DEVICE_MODEL := NSLU2