compat-wireless: add support for kernel 2.6.24
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 27 Aug 2010 18:40:53 +0000 (11:40 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Sat, 28 Aug 2010 20:27:59 +0000 (13:27 -0700)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
config.mk
scripts/gen-compat-autoconf.sh

index 27e2322f994f7851871fed590dd22d951c81b9e3..87b637e9d8bb20ee1ea0aa7f96ef9ca0af197b8b 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -25,9 +25,9 @@ KERNEL_SUBLEVEL := $(shell $(MAKE) -C $(KLIB_BUILD) kernelversion | sed -n 's/^2
 COMPAT_VERSIONS := $(shell I=$(COMPAT_LATEST_VERSION); while [ "$$I" -gt $(KERNEL_SUBLEVEL) ]; do echo $$I; I=$$(($$I - 1)); done)
 $(foreach ver,$(COMPAT_VERSIONS),$(eval CONFIG_COMPAT_KERNEL_$(ver)=y))
 
-ifdef CONFIG_COMPAT_KERNEL_25
-$(error "ERROR: compat-wireless by default supports kernels >= 2.6.25, try enabling only one driver though")
-endif #CONFIG_COMPAT_KERNEL_25
+ifdef CONFIG_COMPAT_KERNEL_24
+$(error "ERROR: compat-wireless by default supports kernels >= 2.6.24, try enabling only one driver though")
+endif #CONFIG_COMPAT_KERNEL_24
 
 ifeq ($(CONFIG_CFG80211),y)
 $(error "ERROR: your kernel has CONFIG_CFG80211=y, you should have it CONFIG_CFG80211=m if you want to use this thing.")
index 7b5773c4ba080e4278b21bd87ce452b080b1bc59..65232ab90d9b0f6d3ab5bab656ba6cd0fe921bda 100755 (executable)
@@ -11,7 +11,7 @@
 
 # This indicates which is the oldest kernel we support
 # Update this if you are adding support for older kernels.
-OLDEST_KERNEL_SUPPORTED="2.6.25"
+OLDEST_KERNEL_SUPPORTED="2.6.24"
 COMPAT_RELEASE="compat_version"
 KERNEL_RELEASE="compat_base_tree_version"
 MULT_DEP_FILE=".compat_pivot_dep"