projects
/
openwrt
/
staging
/
xback.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
470ca65
)
kernel: modules: package kmod-crypto-essiv
author
Daniel Golle
<daniel@makrotopia.org>
Sun, 11 Sep 2022 13:26:25 +0000
(14:26 +0100)
committer
Daniel Golle
<daniel@makrotopia.org>
Sun, 11 Sep 2022 18:04:44 +0000
(19:04 +0100)
Package kernel module providing ESSIV support for block encryption.
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/linux/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/crypto.mk
b/package/kernel/linux/modules/crypto.mk
index 35113e12d069abd75246ac9017da72c768af3c20..f8af5f0a3bb2fb45079e4666a5554372bb4af23e 100644
(file)
--- a/
package/kernel/linux/modules/crypto.mk
+++ b/
package/kernel/linux/modules/crypto.mk
@@
-239,6
+239,18
@@
endef
$(eval $(call KernelPackage,crypto-echainiv))
+define KernelPackage/crypto-essiv
+ TITLE:=ESSIV support for block encryption
+ DEPENDS:=+kmod-crypto-authenc
+ KCONFIG:=CONFIG_CRYPTO_ESSIV
+ FILES:= $(LINUX_DIR)/crypto/essiv.ko
+ AUTOLOAD:=$(call AutoLoad,10,essiv)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-essiv))
+
+
define KernelPackage/crypto-fcrypt
TITLE:=FCRYPT cipher CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_FCRYPT