compat-drivers: disable mwifiex for kernels older than 2.6.27
authorLuis R. Rodriguez <mcgrof@do-not-panic.com>
Sat, 17 Nov 2012 03:01:48 +0000 (19:01 -0800)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Sat, 17 Nov 2012 03:02:04 +0000 (19:02 -0800)
mwifiex got Multiqueue support and while we do port multiqueue
I'm really fucking lazy to port this driver particular changes
over given that I really don't think anyone on planet earth will
be using it for kernels older than 2.6.27.

Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
config.mk
patches/network/08-rename-config-options.patch

index dde855439c6641e2c7db314df4e4ac97dba6b9a2..fb5581201e8cd1180547d6c536b069256071f056 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -668,7 +668,9 @@ endif #CONFIG_CRC7
 
 endif #CONFIG_COMPAT_KERNEL_2_6_30
 
-export CONFIG_MWIFIEX=m
+ifndef CONFIG_COMPAT_KERNEL_2_6_27
+export CONFIG_COMPAT_MWIFIEX=m
+endif #CONFIG_COMPAT_KERNEL_2_6_27
 
 ifndef CONFIG_CORDIC
 export CONFIG_COMPAT_CORDIC=y
index 36d4344ee80fc506767cc06701586f6811ec1235..a92760a59876b01047659c1d2ffc32f1076032b2 100644 (file)
@@ -165,3 +165,25 @@ CONFIG_BT_HIDP does not build with older kernel versions.
                lock_sock(sk);
                err = rfcomm_dev_ioctl(sk, cmd, (void __user *) arg);
                release_sock(sk);
+--- a/drivers/net/wireless/Makefile
++++ b/drivers/net/wireless/Makefile
+@@ -38,7 +38,7 @@ obj-$(CONFIG_MAC80211_HWSIM) += mac80211
+ obj-$(CONFIG_WL_TI)   += ti/
+-obj-$(CONFIG_MWIFIEX) += mwifiex/
++obj-$(CONFIG_COMPAT_MWIFIEX)  += mwifiex/
+ obj-$(CONFIG_BRCMFMAC)        += brcm80211/
+ obj-$(CONFIG_BRCMSMAC)        += brcm80211/
+--- a/drivers/net/wireless/mwifiex/Makefile
++++ b/drivers/net/wireless/mwifiex/Makefile
+@@ -39,7 +39,7 @@ mwifiex-y += sta_rx.o
+ mwifiex-y += uap_txrx.o
+ mwifiex-y += cfg80211.o
+ mwifiex-$(CONFIG_DEBUG_FS) += debugfs.o
+-obj-$(CONFIG_MWIFIEX) += mwifiex.o
++obj-$(CONFIG_COMPAT_MWIFIEX) += mwifiex.o
+ mwifiex_sdio-y += sdio.o
+ obj-$(CONFIG_MWIFIEX_SDIO) += mwifiex_sdio.o