compat-wireless: make patches apply again
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 9 Jun 2011 22:03:35 +0000 (00:03 +0200)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 14 Jun 2011 18:13:23 +0000 (11:13 -0700)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
patches/08-rename-config-options.patch
patches/09-threaded-irq.patch
patches/35-fix-makefile-includes.patch

index fdc23220bc5c4d6e8a4360ae840e9c555ffa4779..3fa9c41b03f07eec768e68593a76d10d2f5c49ec 100644 (file)
@@ -35,7 +35,7 @@ CONFIG_BT_HIDP does not build with older kernel versions.
  iwl4965-objs          += iwl-4965-lib.o iwl-4965-rx.o iwl-4965-calib.o
 --- a/drivers/net/wireless/iwlegacy/iwl-dev.h
 +++ b/drivers/net/wireless/iwlegacy/iwl-dev.h
-@@ -1221,7 +1221,7 @@ struct iwl_priv {
+@@ -1211,7 +1211,7 @@ struct iwl_priv {
  
                } _3945;
  #endif
@@ -69,7 +69,7 @@ CONFIG_BT_HIDP does not build with older kernel versions.
                zd_rf_al2230.o zd_rf_rf2959.o \
 --- a/include/net/bluetooth/bluetooth.h
 +++ b/include/net/bluetooth/bluetooth.h
-@@ -205,7 +205,7 @@ extern void bt_sysfs_cleanup(void);
+@@ -213,7 +213,7 @@ extern void bt_sysfs_cleanup(void);
  
  extern struct dentry *bt_debugfs;
  
@@ -78,7 +78,7 @@ CONFIG_BT_HIDP does not build with older kernel versions.
  int l2cap_init(void);
  void l2cap_exit(void);
  #else
-@@ -219,7 +219,7 @@ static inline void l2cap_exit(void)
+@@ -227,7 +227,7 @@ static inline void l2cap_exit(void)
  }
  #endif
  
@@ -97,9 +97,9 @@ CONFIG_BT_HIDP does not build with older kernel versions.
 +obj-$(CONFIG_COMPAT_BT_HIDP)  += hidp/
  
  bluetooth-y := af_bluetooth.o hci_core.o hci_conn.o hci_event.o mgmt.o hci_sock.o hci_sysfs.o lib.o
--bluetooth-$(CONFIG_BT_L2CAP)  += l2cap_core.o l2cap_sock.o
+-bluetooth-$(CONFIG_BT_L2CAP)  += l2cap_core.o l2cap_sock.o smp.o
 -bluetooth-$(CONFIG_BT_SCO)    += sco.o
-+bluetooth-$(CONFIG_COMPAT_BT_L2CAP)   += l2cap_core.o l2cap_sock.o
++bluetooth-$(CONFIG_COMPAT_BT_L2CAP)   += l2cap_core.o l2cap_sock.o smp.o
 +bluetooth-$(CONFIG_COMPAT_BT_SCO)     += sco.o
 --- a/net/bluetooth/hidp/Makefile
 +++ b/net/bluetooth/hidp/Makefile
index acfe0434f8c3d0b005c3ec40a33fb1520c61f743..901356225120ed5fb5aa3896015f1acf14adcac2 100644 (file)
@@ -6,39 +6,39 @@ thread in process context as well.
 
 --- a/drivers/net/wireless/b43/main.c
 +++ b/drivers/net/wireless/b43/main.c
-@@ -3970,8 +3970,13 @@ redo:
-       if (dev->sdev->bus->bustype == SSB_BUSTYPE_SDIO) {
+@@ -3984,8 +3984,13 @@ redo:
+       if (b43_bus_host_is_sdio(dev->dev)) {
                b43_sdio_free_irq(dev);
        } else {
 +#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,31)
 +              compat_synchronize_threaded_irq(&dev->irq_compat);
 +              compat_free_threaded_irq(&dev->irq_compat);
 +#else
-               synchronize_irq(dev->sdev->irq);
-               free_irq(dev->sdev->irq, dev);
+               synchronize_irq(dev->dev->irq);
+               free_irq(dev->dev->irq, dev);
 +#endif
        }
        mutex_lock(&wl->mutex);
        dev = wl->current_dev;
-@@ -4011,9 +4016,17 @@ static int b43_wireless_core_start(struc
+@@ -4025,9 +4030,17 @@ static int b43_wireless_core_start(struc
                        goto out;
                }
        } else {
 +#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,31)
 +              err = compat_request_threaded_irq(&dev->irq_compat,
-+                                                dev->sdev->irq,
++                                                dev->dev->irq,
 +                                                b43_interrupt_handler,
 +                                                b43_interrupt_thread_handler,
 +                                                IRQF_SHARED, KBUILD_MODNAME, dev);
 +#else
-               err = request_threaded_irq(dev->sdev->irq, b43_interrupt_handler,
+               err = request_threaded_irq(dev->dev->irq, b43_interrupt_handler,
                                           b43_interrupt_thread_handler,
                                           IRQF_SHARED, KBUILD_MODNAME, dev);
 +#endif
                if (err) {
                        b43err(dev->wl, "Cannot request IRQ-%d\n",
-                              dev->sdev->irq);
-@@ -4728,6 +4741,10 @@ static int b43_setup_bands(struct b43_wl
+                              dev->dev->irq);
+@@ -4744,6 +4757,10 @@ static int b43_setup_bands(struct b43_wl
  
  static void b43_wireless_core_detach(struct b43_wldev *dev)
  {
@@ -51,7 +51,7 @@ thread in process context as well.
        b43_release_firmware(dev);
 --- a/drivers/net/wireless/b43/b43.h
 +++ b/drivers/net/wireless/b43/b43.h
-@@ -772,6 +772,9 @@ struct b43_wldev {
+@@ -786,6 +786,9 @@ struct b43_wldev {
        unsigned int tx_count;
        unsigned int rx_count;
  #endif
@@ -63,7 +63,7 @@ thread in process context as well.
  /* Data structure for the WLAN parts (802.11 cores) of the b43 chip. */
 --- a/drivers/net/wireless/wl12xx/spi.c
 +++ b/drivers/net/wireless/wl12xx/spi.c
-@@ -405,10 +405,14 @@ static int __devinit wl1271_probe(struct
+@@ -406,10 +406,14 @@ static int __devinit wl1271_probe(struct
        wl->tcxo_clock = pdata->board_tcxo_clock;
        wl->platform_quirks = pdata->platform_quirks;
  
@@ -78,7 +78,7 @@ thread in process context as well.
  
        wl->irq = spi->irq;
        if (wl->irq < 0) {
-@@ -417,9 +421,16 @@ static int __devinit wl1271_probe(struct
+@@ -418,9 +422,16 @@ static int __devinit wl1271_probe(struct
                goto out_free;
        }
  
@@ -95,7 +95,7 @@ thread in process context as well.
        if (ret < 0) {
                wl1271_error("request_irq() failed: %d", ret);
                goto out_free;
-@@ -440,7 +451,11 @@ static int __devinit wl1271_probe(struct
+@@ -441,7 +452,11 @@ static int __devinit wl1271_probe(struct
        return 0;
  
   out_irq:
@@ -107,7 +107,7 @@ thread in process context as well.
  
   out_free:
        wl1271_free_hw(wl);
-@@ -453,7 +468,12 @@ static int __devexit wl1271_remove(struc
+@@ -454,7 +469,12 @@ static int __devexit wl1271_remove(struc
        struct wl1271 *wl = dev_get_drvdata(&spi->dev);
  
        wl1271_unregister_hw(wl);
@@ -122,7 +122,7 @@ thread in process context as well.
        return 0;
 --- a/drivers/net/wireless/wl12xx/wl12xx.h
 +++ b/drivers/net/wireless/wl12xx/wl12xx.h
-@@ -593,6 +593,10 @@ struct wl1271 {
+@@ -594,6 +594,10 @@ struct wl1271 {
  
        /* Platform limitations */
        unsigned int platform_quirks;
index 4a01aa2981c2059af524f01fea0ffe59fe203d54..ea8bd8c9fdeaa644c5c41f582fb4f867c7a7e730 100644 (file)
@@ -45,17 +45,17 @@ path the make process will search in the kernel tree for the headers.
 +      -I$(obj)/../include
  
  BRCMSMAC_OFILES := \
-       wl_mac80211.o \
---- a/drivers/staging/brcm80211/util/Makefile
-+++ b/drivers/staging/brcm80211/util/Makefile
+       mac80211_if.o \
+--- a/drivers/staging/brcm80211/brcmutil/Makefile
++++ b/drivers/staging/brcm80211/brcmutil/Makefile
 @@ -16,8 +16,8 @@
  # CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
  
  ccflags-y :=                          \
--      -Idrivers/staging/brcm80211/util \
+-      -Idrivers/staging/brcm80211/brcmutil \
 -      -Idrivers/staging/brcm80211/include
 +      -I$(obj)                        \
 +      -I$(obj)/../include
  
  BRCMUTIL_OFILES := \
-       bcmutils.o \
+       utils.o \