ath79: bsap18x0: pad rootfs image
authorTomasz Maciej Nowak <tmn505@gmail.com>
Mon, 4 Jul 2022 12:23:06 +0000 (14:23 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 15 Jul 2022 13:22:08 +0000 (15:22 +0200)
This image is supposed to be written with help of bootloader to the
flash, but as it stands, it's not aligned to block size and RedBoot will
happily create non-aligned partition size in FIS directory. This could
lead to kernel to mark the partition as read-only, therefore pad the
image to block erase size boundary.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
(cherry picked from commit 9decd2a8436d2bb6b5f436268c92a6e6728486ce)

target/linux/ath79/image/generic.mk

index 2b81690654e6385a69b551f8aa2cd98b309b5ae5..2d4d1e5c91b828d0e066da2b7ac0c90996e37e79 100644 (file)
@@ -208,7 +208,7 @@ define Device/adtran_bsap1880
   IMAGE_SIZE := 11200k
   IMAGES += kernel.bin rootfs.bin
   IMAGE/kernel.bin := append-kernel
-  IMAGE/rootfs.bin := append-rootfs | pad-rootfs
+  IMAGE/rootfs.bin := append-rootfs | pad-rootfs | pad-to $$(BLOCKSIZE)
   IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | \
        check-size | sysupgrade-tar rootfs=$$$$@ | append-metadata
 endef