package: fix key creation for SDK
authorPaul Spooren <mail@aparcar.org>
Mon, 28 Oct 2024 21:33:48 +0000 (22:33 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 28 Oct 2024 23:07:55 +0000 (00:07 +0100)
Prior to this commit keys would only be generated if `make` is called
alone, but not for something like `make package/busybox/compile`.

The exact reasons are in the depth of make magic, so this is sheer luck!

Signed-off-by: Paul Spooren <mail@aparcar.org>
package/Makefile

index 70897271ac3c3d91a322b3a7599906fefe2604de..9ae94e9a4eb696681a59f704f107b5f0c915e7a4 100644 (file)
@@ -87,7 +87,7 @@ else
 endif
 else
 ifneq ($(CONFIG_USE_APK),)
-  $(curdir)/compile: $(BUILD_KEY_APK_SEC) $(BUILD_KEY_APK_PUB)
+  $(curdir)//compile += $(BUILD_KEY_APK_SEC) $(BUILD_KEY_APK_PUB)
 endif
 endif