bcm53xx: enable Broadcom 4366b1 firmware for Asus RT-AC88U
authorArınç ÜNAL <arinc.unal@arinc9.com>
Tue, 18 Oct 2022 08:54:20 +0000 (11:54 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 23 Oct 2022 12:21:03 +0000 (14:21 +0200)
On some of the hardware revisions of Asus RT-AC88U, brcmfmac detects the
4366b1 wireless chip and tries to load the firmware file which doesn't
exist because it's not included in the image.

Therefore, include firmware for 4366b1 along with 4366c0. This way, all
hardware revisions of the router will be supported by having brcmfmac use
the firmware file for the wireless chip it detects.

Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com>
(cherry picked from commit 2b9bb5b187022f8b64c84781c071d6c2b0ce3e45)

target/linux/bcm53xx/image/Makefile

index fc85a131cc5ea2df766c39553818530a755073b9..dcfa3a239eed97c36ffa343b5521bc8b40dec7fa 100644 (file)
@@ -170,7 +170,7 @@ TARGET_DEVICES += asus_rt-ac87u
 define Device/asus_rt-ac88u
   $(call Device/asus)
   DEVICE_MODEL := RT-AC88U
-  DEVICE_PACKAGES := $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+  DEVICE_PACKAGES := $(BRCMFMAC_4366B1) $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
   ASUS_PRODUCTID := RT-AC88U
 endef
 TARGET_DEVICES += asus_rt-ac88u