projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3204eaf
)
ncurses: install a dummy libtinfo.a for packages that try to link it
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 11 May 2016 10:49:26 +0000
(10:49 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 11 May 2016 10:49:26 +0000
(10:49 +0000)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
SVN-Revision: 49373
package/libs/ncurses/Makefile
patch
|
blob
|
history
diff --git
a/package/libs/ncurses/Makefile
b/package/libs/ncurses/Makefile
index 94da02e2b9544be271df2c59822a91a3c88c910d..d97d0b53cdb5e9d64b6980f2c133aa1473e5a93b 100644
(file)
--- a/
package/libs/ncurses/Makefile
+++ b/
package/libs/ncurses/Makefile
@@
-127,6
+127,7
@@
define Build/InstallDev
for lib in ncurses panel menu form; do \
ln -s lib$$$${lib}w.so $(1)/usr/lib/lib$$$${lib}.so; \
done
+ $(TARGET_CROSS)ar rc $(1)/usr/lib/libtinfo.a
$(INSTALL_DIR) $(2)/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/ncursesw5-config $(2)/bin/
$(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' -e 's/$$$$INCS //g' \