wolfssl: remove --enable-sha512 configure switch
authorAndre Heider <a.heider@gmail.com>
Sat, 2 Oct 2021 08:40:00 +0000 (10:40 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 23 Oct 2021 10:37:51 +0000 (12:37 +0200)
It's the default anyway and this just looks confusing, as if it wasn't.

Switch to AUTORELEASE while at it.

The binary size is unchanged.

Signed-off-by: Andre Heider <a.heider@gmail.com>
(cherry picked from commit 7cb5af30f48d6788cd471138820a772610a7f8e0)

package/libs/wolfssl/Makefile

index 937828c9a01842d6dd0bc40e170dbc87d4160283..47501306c88c8be72dc88f39ddfdea323a4823c9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wolfssl
 PKG_VERSION:=4.8.1-stable
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/wolfSSL/wolfssl/archive/v$(PKG_VERSION)
@@ -102,7 +102,7 @@ endif
 
 ifeq ($(CONFIG_WOLFSSL_HAS_WPAS),y)
 CONFIGURE_ARGS += \
-       --enable-wpas --enable-sha512 --enable-fortress --enable-fastmath
+       --enable-wpas --enable-fortress --enable-fastmath
 endif
 
 define Build/InstallDev