fix squid 2.6 config generation
authorTim Yardley <lst@openwrt.org>
Wed, 9 May 2007 21:08:54 +0000 (21:08 +0000)
committerTim Yardley <lst@openwrt.org>
Wed, 9 May 2007 21:08:54 +0000 (21:08 +0000)
SVN-Revision: 7150

net/squid/patches/006-makefile.in.patch [new file with mode: 0644]

diff --git a/net/squid/patches/006-makefile.in.patch b/net/squid/patches/006-makefile.in.patch
new file mode 100644 (file)
index 0000000..0ef5c96
--- /dev/null
@@ -0,0 +1,11 @@
+--- squid-2.6.STABLE12/src/Makefile.in.orig    2007-05-09 16:04:01.000000000 -0500
++++ squid-2.6.STABLE12/src/Makefile.in 2007-05-09 16:06:31.000000000 -0500
+@@ -1210,7 +1210,7 @@
+ cf_parser.h: cf.data cf_gen$(EXEEXT)
+       rm -f cf_gen
+       gcc -c ctype.c
+-      gcc -o cf_gen cf_gen.c -DNODEBUG=1 -I./ -I../ -I../include/ $(CPPFLAGS) -L../lib -lmiscutil$(shell uname -m) -lm -lnsl -Wl,ctype.o
++      gcc -o cf_gen cf_gen.c -DNODEBUG=1 -I./ -I../ -I../include/ -L../lib -lmiscutil$(shell uname -m) -lm -lnsl -Wl,ctype.o
+       ./cf_gen cf.data 
+ cf_gen_defines.h: $(srcdir)/cf_gen_defines $(srcdir)/cf.data.pre