mt76: update to Git HEAD (2024-10-10)
authorFelix Fietkau <nbd@nbd.name>
Thu, 10 Oct 2024 08:49:53 +0000 (10:49 +0200)
committerFelix Fietkau <nbd@nbd.name>
Thu, 10 Oct 2024 08:53:03 +0000 (10:53 +0200)
86b41a32a5ac wifi: mac80211: don't use rate mask for offchannel TX either
82a452919f52 wifi: mac80211: handle ieee80211_radar_detected() for MLO
02c07fe539b4 wifi: mt76: mt7996: fix rx filter setting for bfee functionality
a902bfa6db2f wifi: mt76: mt7915: disable the second PCIe link for MT7915
a7d48cd3ed34 wifi: mt76: mt7915: reduce the number of command retries
0d8474602a9b wifi: mt76: mt7915: decrease timeout for commonly issued MCU commands
5f6051569639 wifi: mt76: mt7915: add module param to select 5 GHz or 6 GHz on MT7916
f5bccb122305 wifi: mt76: mt7996: fix invalid interface combinations
6a1199463fc8 wifi: mt76: mt7915: Fix an error handling path in mt7915_add_interface()

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/mt76/Makefile
package/kernel/mt76/patches/100-api_update.patch [deleted file]

index 070d0f3c2b588b4e1a7dbfd7b3843c2ff4cd1c14..957159201c5b2d27b157055e9b103e22c1b37b6d 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/openwrt/mt76
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2024-09-29
-PKG_SOURCE_VERSION:=680bc70f161fde0f167e2ae50c771be4775eb50a
-PKG_MIRROR_HASH:=bcdb95e40cfceba56a565ad6b6d9f92a122e7230d0f7f950b3d39e4280723cca
+PKG_SOURCE_DATE:=2024-10-10
+PKG_SOURCE_VERSION:=6a1199463fc8f7758c32122613288ed95c09e3bd
+PKG_MIRROR_HASH:=4b42a586e098c1dc5970fbd3190ac2faf67992c7357161a3ef3040817a8ed8d6
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_USE_NINJA:=0
diff --git a/package/kernel/mt76/patches/100-api_update.patch b/package/kernel/mt76/patches/100-api_update.patch
deleted file mode 100644 (file)
index 4cd19f6..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
---- a/tx.c
-+++ b/tx.c
-@@ -350,7 +350,7 @@ mt76_tx(struct mt76_phy *phy, struct iee
-       info->hw_queue |= FIELD_PREP(MT_TX_HW_QUEUE_PHY, phy->band_idx);
-       if ((info->flags & IEEE80211_TX_CTL_TX_OFFCHAN) ||
--          (info->control.flags & IEEE80211_TX_CTRL_SCAN_TX))
-+          (info->control.flags & IEEE80211_TX_CTRL_DONT_USE_RATE_MASK))
-               head = &wcid->tx_offchannel;
-       else
-               head = &wcid->tx_pending;
---- a/mt7615/mcu.c
-+++ b/mt7615/mcu.c
-@@ -394,7 +394,7 @@ mt7615_mcu_rx_radar_detected(struct mt76
-       if (mt76_phy_dfs_state(mphy) < MT_DFS_STATE_CAC)
-               return;
--      ieee80211_radar_detected(mphy->hw);
-+      ieee80211_radar_detected(mphy->hw, NULL);
-       dev->hw_pattern++;
- }
---- a/mt76x02_dfs.c
-+++ b/mt76x02_dfs.c
-@@ -630,7 +630,7 @@ static void mt76x02_dfs_tasklet(struct t
-               radar_detected = mt76x02_dfs_check_detection(dev);
-               if (radar_detected) {
-                       /* sw detector rx radar pattern */
--                      ieee80211_radar_detected(dev->mt76.hw);
-+                      ieee80211_radar_detected(dev->mt76.hw, NULL);
-                       mt76x02_dfs_detector_reset(dev);
-                       return;
-@@ -658,7 +658,7 @@ static void mt76x02_dfs_tasklet(struct t
-               /* hw detector rx radar pattern */
-               dfs_pd->stats[i].hw_pattern++;
--              ieee80211_radar_detected(dev->mt76.hw);
-+              ieee80211_radar_detected(dev->mt76.hw, NULL);
-               mt76x02_dfs_detector_reset(dev);
-               return;
---- a/mt7915/mcu.c
-+++ b/mt7915/mcu.c
-@@ -297,7 +297,7 @@ mt7915_mcu_rx_radar_detected(struct mt79
-                                               &dev->rdd2_chandef,
-                                               GFP_ATOMIC);
-       else
--              ieee80211_radar_detected(mphy->hw);
-+              ieee80211_radar_detected(mphy->hw, NULL);
-       dev->hw_pattern++;
- }
---- a/mt7996/mcu.c
-+++ b/mt7996/mcu.c
-@@ -383,7 +383,7 @@ mt7996_mcu_rx_radar_detected(struct mt79
-                                               &dev->rdd2_chandef,
-                                               GFP_ATOMIC);
-       else
--              ieee80211_radar_detected(mphy->hw);
-+              ieee80211_radar_detected(mphy->hw, NULL);
-       dev->hw_pattern++;
- }