projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3209b13
)
mt76: include generated mac80211 config file and add an appropriate define for mesh...
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 8 May 2015 21:46:42 +0000
(21:46 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 8 May 2015 21:46:42 +0000
(21:46 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45649
package/kernel/mt76/Makefile
patch
|
blob
|
history
diff --git
a/package/kernel/mt76/Makefile
b/package/kernel/mt76/Makefile
index 31cd1208cb34cd18f7563bf552b6c6e76fa362ff..561f6069b23fca76a0825e76e72c3880cfede58a 100644
(file)
--- a/
package/kernel/mt76/Makefile
+++ b/
package/kernel/mt76/Makefile
@@
-33,8
+33,13
@@
NOSTDINC_FLAGS = \
-I$(STAGING_DIR)/usr/include/mac80211-backport \
-I$(STAGING_DIR)/usr/include/mac80211/uapi \
-I$(STAGING_DIR)/usr/include/mac80211 \
+ -include backport/autoconf.h \
-include backport/backport.h
+ifdef CONFIG_PACKAGE_MAC80211_MESH
+ NOSTDINC_FLAGS += -DCONFIG_MAC80211_MESH
+endif
+
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C "$(LINUX_DIR)" \
ARCH="$(LINUX_KARCH)" \