projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d560deb
)
busybox: add ALTERNATIVES for wget
author
Hans Dedecker
<dedeckeh@gmail.com>
Fri, 11 Jan 2019 15:15:57 +0000
(16:15 +0100)
committer
Hans Dedecker
<dedeckeh@gmail.com>
Sun, 13 Jan 2019 17:27:28 +0000
(18:27 +0100)
Busybox wget applet conflicts with the version from uclient.
Fix this by using ALTERNATIVE support for wget in busybox.
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/utils/busybox/Makefile
patch
|
blob
|
history
diff --git
a/package/utils/busybox/Makefile
b/package/utils/busybox/Makefile
index 80e8846a56b1d56575cb7c93d9fa60f166c3be38..82f33d131f0c93b748ba11a680efdeb4fbd5e85c 100644
(file)
--- a/
package/utils/busybox/Makefile
+++ b/
package/utils/busybox/Makefile
@@
-60,6
+60,7
@@
define Package/busybox
$(call BUSYBOX_IF_ENABLED,UPTIME, 100:/usr/bin/uptime:/bin/busybox) \
$(call BUSYBOX_IF_ENABLED,WATCH, 100:/bin/watch:/bin/busybox) \
$(call BUSYBOX_IF_ENABLED,XARGS, 100:/usr/bin/xargs:/bin/busybox) \
+ $(call BUSYBOX_IF_ENABLED,WGET, 100:/usr/bin/wget:/bin/busybox) \
endef