[package] update miredo to 1.1.6 (#5204)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 26 May 2009 14:40:17 +0000 (14:40 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 26 May 2009 14:40:17 +0000 (14:40 +0000)
SVN-Revision: 16083

net/miredo/Makefile
net/miredo/patches/100-uclibc.patch

index d763b0b74b7ca2b5ea694bf17b49b29558000b5e..afe1503501ff1c024912cc1987fe35e42ea06cc4 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=miredo
-PKG_VERSION:=1.0.0
+PKG_VERSION:=1.1.6
 PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=http://www.remlab.net/files/miredo/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=b5a51cb98732decc2ada96b2caee5d3c
+PKG_MD5SUM:=bf49c1ddc068746760787d0cf76e40de
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -53,6 +53,7 @@ CONFIGURE_ARGS += \
        --enable-teredo-relay \
        --enable-teredo-server \
        --enable-miredo-user=root \
+       --without-Judy \
 
 CONFIGURE_VARS += \
        CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
index b169202106946f543536943dd03074140c683d2f..46573feba1ed954e3229df1965550a9096fc8188 100644 (file)
@@ -1,13 +1,12 @@
-Index: miredo-1.0.0/libteredo/maintain.c
-===================================================================
---- miredo-1.0.0.orig/libteredo/maintain.c     2007-12-30 16:39:41.032377076 +0100
-+++ miredo-1.0.0/libteredo/maintain.c  2007-12-30 16:39:54.569148495 +0100
-@@ -62,7 +62,7 @@
- #define PROBE_SYMMETRIC       3
- #define NOT_RUNNING   (-1)
+diff -urN miredo-1.1.6/libteredo/maintain.c miredo-1.1.6.new/libteredo/maintain.c
+--- miredo-1.1.6/libteredo/maintain.c  2009-04-13 11:15:15.000000000 +0200
++++ miredo-1.1.6.new/libteredo/maintain.c      2009-05-26 16:37:14.000000000 +0200
+@@ -59,7 +59,7 @@
  
--#if (_POSIX_CLOCK_SELECTION - 0 >= 0) && (_POSIX_MONOTONIC_CLOCK - 0 >= 0)
-+#if (_POSIX_CLOCK_SELECTION - 0 >= 0) && (_POSIX_MONOTONIC_CLOCK - 0 >= 0) && !defined(__UCLIBC__)
  static inline void gettime (struct timespec *now)
  {
-       if (clock_gettime (CLOCK_MONOTONIC, now))
+-#if (_POSIX_CLOCK_SELECTION - 0 >= 0) && (_POSIX_MONOTONIC_CLOCK - 0 >= 0)
++#if (_POSIX_CLOCK_SELECTION - 0 >= 0) && (_POSIX_MONOTONIC_CLOCK - 0 >= 0) && !defined(__UCLIBC__)
+       if (clock_gettime (CLOCK_MONOTONIC, now) == 0)
+               return;
+ #else