backport build system: don't pipe yes '' to defconfig
authorJohannes Berg <johannes.berg@intel.com>
Mon, 15 Apr 2013 23:29:58 +0000 (01:29 +0200)
committerJohannes Berg <johannes.berg@intel.com>
Mon, 15 Apr 2013 23:29:58 +0000 (01:29 +0200)
There's no need to pipe yes '' to make defconfig since
it will not ask for anything anyway, and even if it did
the user should probably be asked ...

Signed-off-by: Johannes Berg <johannes.berg@intel.com>
backport/Makefile.real

index fc02bd826d093771be25caa9f0ede76c565bc640..243f904fbed180e7606a6cd10efafe0baca74956 100644 (file)
@@ -37,7 +37,7 @@ defconfig-%::
        @./kconfig/conf --defconfig=defconfigs/$(@:defconfig-%=%) Kconfig
 
 .config:
-       @test -f defconfig && (yes '' | $(MAKE) usedefconfig) || (      \
+       @test -f defconfig && $(MAKE) usedefconfig || (                 \
        echo "/--------------"                                          ;\
        echo "| Your backport package isn't configured, please configure it" ;\
        echo "| using one of the following options:"                    ;\