ipq40xx: cambium wip
authorDavid Bauer <mail@david-bauer.net>
Mon, 4 Oct 2021 15:51:40 +0000 (17:51 +0200)
committerDavid Bauer <mail@david-bauer.net>
Mon, 3 Apr 2023 01:14:58 +0000 (03:14 +0200)
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-cnpilot-e410-a.dts [new file with mode: 0644]
target/linux/ipq40xx/image/generic.mk

diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-cnpilot-e410-a.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-cnpilot-e410-a.dts
new file mode 100644 (file)
index 0000000..2fc9175
--- /dev/null
@@ -0,0 +1,169 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "Cambium Networks cnPilot e410 A";
+       compatible = "cambium,cnpilot-e410-a";
+
+       aliases {
+               label-mac-device = &gmac0;
+       };
+
+       soc {
+               rng@22000 {
+                       status = "okay";
+               };
+
+               mdio@90000 {
+                       status = "okay";
+               };
+
+               ess-psgmii@98000 {
+                       status = "okay";
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               tcsr@194b000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+
+               usb2@60f8800 {
+                       status = "okay";
+               };
+
+               usb3@8af8800 {
+                       status = "okay";
+               };
+
+               crypto@8e3a000 {
+                       status = "okay";
+               };
+
+               watchdog@b017000 {
+                       status = "okay";
+               };
+
+               ess-switch@c000000 {
+                       status = "okay";
+               };
+
+               edma@c080000 {
+                       status = "okay";
+               };
+       };
+};
+
+&tlmm {
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio60", "gpio61";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       spi_0_pins: spi_0_pinmux {
+               mux {
+                       function = "blsp_spi0";
+                       pins = "gpio55", "gpio56", "gpio57";
+                       drive-strength = <12>;
+                       bias-disable;
+               };
+
+               mux_cs {
+                       function = "gpio";
+                       pins = "gpio54", "gpio59";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&blsp1_spi1 { /* BLSP1 QUP1 */
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>, <&tlmm 59 GPIO_ACTIVE_HIGH>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition0@0 {
+                               label = "flash";
+                               reg = <0x0 0x2000000>;
+                               read-only;
+                       };
+               };
+       };
+
+       flash@1 {
+               compatible = "spi-nand";
+               reg = <1>;
+               spi-max-frequency = <24000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition0@0 {
+                               label = "flash";
+                               reg = <0x0 0x8000000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&blsp1_uart1 {
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+       status = "okay";
+};
+
+&wifi0 {
+       status = "okay";
+};
+
+&wifi1 {
+       status = "okay";
+};
index 48514b88416275a05d831825a8a9eb2b4ef73c65..be8ab08ce36a05ac40d0fc6cba419cc9eb88cb79 100644 (file)
@@ -343,6 +343,15 @@ endef
 # Missing DSA Setup
 #TARGET_DEVICES += cilab_meshpoint-one
 
+define Device/cambium_dnpilot-e410-a
+       $(call Device/FitImageLzma)
+       DEVICE_VENDOR := Cambium Networks
+       DEVICE_MODEL := cnPilot e410
+       DEVICE_VARIANT := A
+       SOC := qcom-ipq4018
+endef
+TARGET_DEVICES += cambium_dnpilot-e410-a
+
 define Device/compex_wpj419
        $(call Device/FitImage)
        $(call Device/UbiFit)