Move net/rfkill patches to 03-rfkill.patch
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 4 Aug 2009 18:15:14 +0000 (11:15 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 4 Aug 2009 18:15:14 +0000 (11:15 -0700)
Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
compat/compat.diff
compat/diffs/03-rfkill.patch

index 208d312b55b08d1a13d7ef25ed0e9d6630782bd8..befb8c5cfc4b10ea57a378afcae2010c15cf7f52 100644 (file)
  
        return ops;
  }
---- a/net/rfkill/Makefile
-+++ b/net/rfkill/Makefile
-@@ -2,6 +2,6 @@
- # Makefile for the RF switch subsystem.
- #
--rfkill-y                      += core.o
--rfkill-$(CONFIG_RFKILL_INPUT) += input.o
--obj-$(CONFIG_RFKILL)          += rfkill.o
-+rfkill_backport-y                     += core.o
-+rfkill_backport-$(CONFIG_RFKILL_BACKPORT_INPUT)       += input.o
-+obj-$(CONFIG_RFKILL_BACKPORT)         += rfkill_backport.o
---- a/net/rfkill/input.c       2009-07-07 17:27:09.290706860 -0700
-+++ b/net/rfkill/input.c       2009-07-07 17:26:57.195684653 -0700
-@@ -17,7 +17,11 @@
- #include <linux/slab.h>
- #include <linux/workqueue.h>
- #include <linux/init.h>
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31))
- #include <linux/rfkill.h>
-+#else
-+#include <linux/rfkill_backport.h>
-+#endif
- #include <linux/sched.h>
- #include "rfkill.h"
-@@ -229,7 +233,7 @@ static int rfkill_connect(struct input_h
-       handle->dev = dev;
-       handle->handler = handler;
--      handle->name = "rfkill";
-+      handle->name = "rfkill_backport";
-       /* causes rfkill_start() to be called */
-       error = input_register_handle(handle);
 --- a/net/wireless/core.h      2009-07-07 13:32:53.367707921 -0700
 +++ b/net/wireless/core.h      2009-07-07 13:32:53.943703622 -0700
 @@ -11,7 +11,11 @@
index 0f3b462939bccb4cfa09ada5faf51d535f3ea49a..c6ffa863e9425cef6c2a3affddee1af66b136d85 100644 (file)
@@ -1,3 +1,38 @@
+--- a/net/rfkill/Makefile
++++ b/net/rfkill/Makefile
+@@ -2,6 +2,6 @@
+ # Makefile for the RF switch subsystem.
+ #
+-rfkill-y                      += core.o
+-rfkill-$(CONFIG_RFKILL_INPUT) += input.o
+-obj-$(CONFIG_RFKILL)          += rfkill.o
++rfkill_backport-y                     += core.o
++rfkill_backport-$(CONFIG_RFKILL_BACKPORT_INPUT)       += input.o
++obj-$(CONFIG_RFKILL_BACKPORT)         += rfkill_backport.o
+--- a/net/rfkill/input.c       2009-07-07 17:27:09.290706860 -0700
++++ b/net/rfkill/input.c       2009-07-07 17:26:57.195684653 -0700
+@@ -17,7 +17,11 @@
+ #include <linux/slab.h>
+ #include <linux/workqueue.h>
+ #include <linux/init.h>
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31))
+ #include <linux/rfkill.h>
++#else
++#include <linux/rfkill_backport.h>
++#endif
+ #include <linux/sched.h>
+ #include "rfkill.h"
+@@ -229,7 +233,7 @@ static int rfkill_connect(struct input_h
+       handle->dev = dev;
+       handle->handler = handler;
+-      handle->name = "rfkill";
++      handle->name = "rfkill_backport";
+       /* causes rfkill_start() to be called */
+       error = input_register_handle(handle);
 --- a/net/rfkill/core.c        2009-08-04 10:54:43.078999821 -0700
 +++ b/net/rfkill/core.c        2009-08-04 10:54:43.555024585 -0700
 @@ -26,7 +26,7 @@