projects
/
openwrt
/
staging
/
jogo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7f35802
)
uClibc for x86 targets and kernels >= 2.6.24 need to copy the right include files...
author
Florian Fainelli
<florian@openwrt.org>
Mon, 21 Jul 2008 10:41:27 +0000
(10:41 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Mon, 21 Jul 2008 10:41:27 +0000
(10:41 +0000)
SVN-Revision: 11893
toolchain/uClibc/Makefile
patch
|
blob
|
history
diff --git
a/toolchain/uClibc/Makefile
b/toolchain/uClibc/Makefile
index 8c02489b1431d168a5519614ac61d9042d84435c..197f736d1e794fa5b6f127b4d239599a39a3de27 100644
(file)
--- a/
toolchain/uClibc/Makefile
+++ b/
toolchain/uClibc/Makefile
@@
-64,6
+64,13
@@
UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
-e 's/cris.*/cris/' \
)
+# Remove me when there are no 2.6.23 targets
+ifeq ($(findstring 86,$(ARCH)),86)
+ ifneq ($(LINUX_2_6_23),y)
+ UCLIBC_TARGET_ARCH:=x86
+ endif
+endif
+
define Build/Prepare/Snapshot
$(PKG_UNPACK)
rm -Rf $(PKG_BUILD_DIR)