bpftool: turn off libbfd feature in host build
authorEric Long <i@hack3r.moe>
Mon, 25 Nov 2024 13:26:47 +0000 (21:26 +0800)
committerRobert Marko <robimarko@gmail.com>
Mon, 9 Dec 2024 10:21:06 +0000 (11:21 +0100)
libbfd feature is not used when building eBPF program, and it makes bpftool fail to build in a clean environment, since binutils in toolchain have libbfd disabled.

Signed-off-by: Eric Long <i@hack3r.moe>
Link: https://github.com/openwrt/openwrt/pull/17073
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/network/utils/bpftool/Makefile

index f2726d189690901aa07fb7bef3fff97dc45338a7..c6cc92e18d16c46b6d02f0c51dfecc6b79523a54 100644 (file)
@@ -97,7 +97,7 @@ HOST_MAKE_FLAGS += \
        $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
        check_feat=0 \
        feature-clang-bpf-co-re=0 \
-       feature-libbfd=1 \
+       feature-libbfd=0 \
        feature-llvm=0 \
        feature-libcap=0 \
        feature-disassembler-four-args=1 \