projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6dc1864
)
kernel: add missing symbol to kmod-qlcnic
author
Stijn Tintel
<stijn@linux-ipv6.be>
Thu, 22 Jul 2021 13:37:12 +0000
(16:37 +0300)
committer
Stijn Tintel
<stijn@linux-ipv6.be>
Fri, 23 Jul 2021 09:33:32 +0000
(12:33 +0300)
When the kmod-qlcnic package is built on targets that have
CONFIG_PCI_IOV enabled, the CONFIG_QLCNIC_SRIOV symbol is exposed.
Enable this symbol in the kmod package to fix its build.
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
package/kernel/linux/modules/netdevices.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/netdevices.mk
b/package/kernel/linux/modules/netdevices.mk
index b91442748d43de11716071a25d81a12267f28fb6..6bbaf21e4aa944ec6eaf2069ee16164f98cea8c5 100644
(file)
--- a/
package/kernel/linux/modules/netdevices.mk
+++ b/
package/kernel/linux/modules/netdevices.mk
@@
-1199,7
+1199,8
@@
define KernelPackage/qlcnic
TITLE:=QLogic QLE8240 and QLE8242 device support
KCONFIG:= \
CONFIG_QLCNIC \
- CONFIG_QLCNIC_HWMON=y
+ CONFIG_QLCNIC_HWMON=y \
+ CONFIG_QLCNIC_SRIOV=y
FILES:=$(LINUX_DIR)/drivers/net/ethernet/qlogic/qlcnic/qlcnic.ko
AUTOLOAD:=$(call AutoProbe,qlcnic)
endef