libdbi: remove CFLAGS override
authorFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:56:29 +0000 (00:56 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 8 Mar 2014 00:56:29 +0000 (00:56 +0000)
libdbi's configure.in is hardcoding CFLAGS and does not allow the configure
script environment to override those. Remove the hardcoded CFLAGS as they are
completely bogus and do not allow for any configuration. Fixes the build on ARM
VFP toolchains.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 39797

libs/libdbi/patches/002-no_cflags_override.patch [new file with mode: 0644]

diff --git a/libs/libdbi/patches/002-no_cflags_override.patch b/libs/libdbi/patches/002-no_cflags_override.patch
new file mode 100644 (file)
index 0000000..d903e64
--- /dev/null
@@ -0,0 +1,45 @@
+--- libdbi-0.8.3/configure.in  2014-03-06 14:04:14.708630767 -0800
++++ libdbi-0.8.3/configure.in  2014-03-06 14:04:53.229096958 -0800
+@@ -32,42 +32,6 @@
+ dnl Set some general compile options
+ dnl ====================================
+-if test -z "$GCC"; then
+-        case $host in
+-        *-*-irix*)
+-                if test -z "$CC"; then
+-                        CC=cc
+-                fi
+-                DEBUG="-g -signed"
+-                CFLAGS="-O2 -w -signed"
+-                PROFILE="-p -g3 -O2 -signed" ;;
+-        sparc-sun-solaris*)
+-                DEBUG="-v -g"
+-                CFLAGS="-xO4 -fast -w -fsimple -native -xcg92"
+-                PROFILE="-v -xpg -g -xO4 -fast -native -fsimple -xcg92 -Dsuncc" ;;
+-        *)
+-                DEBUG="-g"
+-                CFLAGS="-O"
+-                PROFILE="-g -p" ;;
+-        esac
+-else
+-
+-        case $host in
+-        *-*-linux*)
+-                DEBUG="-g -Wall -D_REENTRANT -D__NO_MATH_INLINES -fsigned-char -std=gnu99"
+-                CFLAGS="-O20 -ffast-math -D_REENTRANT -fsigned-char -std=gnu99"
+-                PROFILE="-pg -g -O20 -ffast-math -D_REENTRANT -fsigned-char -std=gnu99";;
+-        sparc-sun-*)
+-                DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char -mv8 -std=gnu99"
+-                CFLAGS="-O20 -ffast-math -D__NO_MATH_INLINES -fsigned-char -mv8 -std=gnu99"
+-                PROFILE="-pg -g -O20 -D__NO_MATH_INLINES -fsigned-char -mv8 -std=gnu99" ;;
+-        *)
+-                DEBUG="-g -Wall -D__NO_MATH_INLINES -fsigned-char -std=gnu99"
+-                CFLAGS="-O20 -D__NO_MATH_INLINES -fsigned-char -std=gnu99"
+-                PROFILE="-O20 -g -pg -D__NO_MATH_INLINES -fsigned-char -std=gnu99" ;;
+-        esac
+-fi
+-
+ AC_SUBST(DEBUG)
+ AC_SUBST(PROFILE)