mysql: fix a compile error on some host systems.
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 9 Apr 2011 12:58:10 +0000 (12:58 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 9 Apr 2011 12:58:10 +0000 (12:58 +0000)
conf_to_src.c uses C++ functions so we should use g++ for compiling.
The CFLAGS, CPPFLAGS and LDFLAGS for host build should be used and not the for target builds.

This closes #8342

SVN-Revision: 26540

libs/mysql/Makefile

index dba90cbad6ff00a302e12bf7105c93b3643b74a0..3dcae75e8726cc51ac28e6e4a0aad238a356b1af 100644 (file)
@@ -120,10 +120,10 @@ define Build/Compile
                DESTDIR="$(PKG_INSTALL_DIR)" \
                install
        $(MAKE) $(PKG_JOBS) -C "$(PKG_BUILD_DIR)/libmysql" \
-               CC="$(HOSTCC)" \
-               LINK="$(HOSTCC) -o conf_to_src -lc" \
-               CFLAGS="" \
-               CPPFLAGS="" \
+               CC="g++" \
+               CFLAGS="$(HOST_CFLAGS)" \
+               CPPFLAGS="$(HOST_CFLAGS)" \
+               LDFLAGS="$(HOST_LDFLAGS)" \
                conf_to_src
        $(MAKE) $(PKG_JOBS) -C "$(PKG_BUILD_DIR)" \
                SUBDIRS="libmysql" \