projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
238bcbc
)
Makefile: Export clang toolchain variables
author
Joel Stanley
<joel@jms.id.au>
Mon, 12 Nov 2018 04:21:15 +0000
(14:51 +1030)
committer
Masahiro Yamada
<yamada.masahiro@socionext.com>
Tue, 13 Nov 2018 23:21:22 +0000
(08:21 +0900)
The powerpc makefile will use these in it's boot wrapper.
Signed-off-by: Joel Stanley <joel@jms.id.au>
Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
Makefile
patch
|
blob
|
history
diff --git
a/Makefile
b/Makefile
index c300ac16c895e336b894824abf938af37da6d964..96b4ea5adf91f5593d67b75b08134897b1a4ee33 100644
(file)
--- a/
Makefile
+++ b/
Makefile
@@
-498,6
+498,7
@@
endif
CLANG_FLAGS += -no-integrated-as
KBUILD_CFLAGS += $(CLANG_FLAGS)
KBUILD_AFLAGS += $(CLANG_FLAGS)
+export CLANG_FLAGS
endif
RETPOLINE_CFLAGS_GCC := -mindirect-branch=thunk-extern -mindirect-branch-register