projects
/
openwrt
/
svn-archive
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
22fbec7
)
grep: simplify package remove
author
Peter Wagner
<tripolar@gmx.at>
Sat, 26 Oct 2013 16:09:40 +0000
(16:09 +0000)
committer
Peter Wagner
<tripolar@gmx.at>
Sat, 26 Oct 2013 16:09:40 +0000
(16:09 +0000)
SVN-Revision: 38543
utils/grep/Makefile
patch
|
blob
|
history
diff --git
a/utils/grep/Makefile
b/utils/grep/Makefile
index b6725c089f2b4e4be04e394417b9a480c18df553..6e648e01700e7f42448f409f613eed6ae4932984 100644
(file)
--- a/
utils/grep/Makefile
+++ b/
utils/grep/Makefile
@@
-44,14
+44,7
@@
endef
define Package/grep/prerm
$${IPKG_INSTROOT}/bin/busybox grep -h 2>&1 | grep -q BusyBox && \
-touch $${IPKG_INSTROOT}/tmp/bb_with_grep
-endef
-
-define Package/grep/postrm
-#!/bin/sh
-[ -f $${IPKG_INSTROOT}/tmp/bb_with_grep ] && \
-ln -sf busybox $${IPKG_INSTROOT}/bin/grep && \
-rm $${IPKG_INSTROOT}/tmp/bb_with_grep
+ln -sf busybox $${IPKG_INSTROOT}/bin/grep
exit 0
endef