linux: use packages kmod-hci-uart and kmod-btusb instead of kmod-bluetooth
authorPaweł Owoc <frut3k7@gmail.com>
Sun, 5 Jan 2025 10:35:18 +0000 (11:35 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 23 Feb 2025 23:08:42 +0000 (00:08 +0100)
Use Bluetooth UART and USB packages separetly.

Signed-off-by: Paweł Owoc <frut3k7@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15118
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/bcm53xx/image/Makefile
target/linux/ipq40xx/image/generic.mk
target/linux/qualcommax/image/ipq807x.mk

index 5a0b2c07a716d2592a55ac6dca9d0fe7310de227..08ed88382d70629af33821afb435a98d261f640f 100644 (file)
@@ -398,7 +398,7 @@ TARGET_DEVICES += meraki_mr26
 define Device/meraki_mr32
   DEVICE_VENDOR := Meraki
   DEVICE_MODEL := MR32
-  DEVICE_PACKAGES := $(B43) kmod-leds-pwm kmod-hwmon-ina2xx kmod-bluetooth
+  DEVICE_PACKAGES := $(B43) kmod-leds-pwm kmod-hwmon-ina2xx kmod-hci-uart
   DEVICE_DTS := bcm53016-meraki-mr32
 # Meraki FW r23 tries to resize the part.safe partition before it will
 # flash the image. This is a bit of a problem, since resizing will fail
index 2071059444e2b6a6d31307350e0c4857b87f3e59..393bb991f11e6a9970fcbc051093043870ec3202 100644 (file)
@@ -739,7 +739,7 @@ define Device/linksys_whw03
        IMAGE_SIZE := 131072k
        IMAGES += factory.bin
        IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | linksys-image type=WHW03
-       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-leds-pca963x kmod-spi-dev kmod-bluetooth \
+       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-leds-pca963x kmod-spi-dev kmod-hci-uart \
                kmod-fs-ext4 e2fsprogs kmod-fs-f2fs mkf2fs losetup ipq-wifi-linksys_whw03
 endef
 TARGET_DEVICES += linksys_whw03
@@ -758,7 +758,7 @@ define Device/linksys_whw03v2
        UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
        IMAGES += factory.bin
        IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=WHW03v2
-       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-leds-pca963x kmod-spi-dev kmod-bluetooth
+       DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-leds-pca963x kmod-spi-dev kmod-hci-uart
 endef
 TARGET_DEVICES += linksys_whw03v2
 
@@ -1127,7 +1127,7 @@ define Device/teltonika_rutx10
        PAGESIZE := 2048
        FILESYSTEMS := squashfs
        IMAGE/factory.ubi := append-ubi | qsdk-ipq-factory-nand | append-rutx-metadata
-       DEVICE_PACKAGES := kmod-bluetooth
+       DEVICE_PACKAGES := kmod-btusb
 endef
 # Missing DSA Setup
 #TARGET_DEVICES += teltonika_rutx10
index 4477e10505f7d1041514f4a56d5b9c2c6bcf83ed..48dd7f7a39399c87e986ec7f16324086b9615b75 100644 (file)
@@ -208,7 +208,7 @@ define Device/linksys_mx4200v1
        $(call Device/linksys_mx4x00)
        DEVICE_MODEL := MX4200
        DEVICE_VARIANT := v1
-       DEVICE_PACKAGES += kmod-bluetooth
+       DEVICE_PACKAGES += kmod-hci-uart
 endef
 TARGET_DEVICES += linksys_mx4200v1
 
@@ -241,7 +241,7 @@ define Device/linksys_mx8500
        $(call Device/linksys_mx)
        DEVICE_MODEL := MX8500
        DEVICE_PACKAGES += ipq-wifi-linksys_mx8500 kmod-ath11k-pci \
-               ath11k-firmware-qcn9074 kmod-bluetooth
+               ath11k-firmware-qcn9074 kmod-hci-uart
 endef
 TARGET_DEVICES += linksys_mx8500
 
@@ -507,6 +507,6 @@ define Device/zyxel_nbg7815
        DEVICE_DTS_CONFIG := config@nbg7815
        SOC := ipq8074
        DEVICE_PACKAGES := kmod-fs-f2fs f2fs-tools ipq-wifi-zyxel_nbg7815 kmod-ath11k-pci \
-               kmod-bluetooth kmod-hwmon-tmp103
+               kmod-hci-uart kmod-hwmon-tmp103
 endef
 TARGET_DEVICES += zyxel_nbg7815