tools/elfutils: simplify and cleanup Makefile
authorMichael Pratt <mcpratt@pm.me>
Thu, 20 Jun 2024 05:28:00 +0000 (01:28 -0400)
committerRobert Marko <robimarko@gmail.com>
Mon, 8 Jul 2024 06:49:43 +0000 (08:49 +0200)
After changes to default host build recipes
and default variable definitions,
several custom definitions can be removed,
and the gnulib recipes replaced
with hooks to common recipes.

Also remove leftover PKG_INSTALL
which has no effect for host builds.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
Link: https://github.com/openwrt/openwrt/pull/15853
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/elfutils/Makefile

index bbbb1da9140faec30e5c523dcfb4e1d88e6a5f8c..2836cadc87d60b66fea2946b4ed2d8490a619522 100644 (file)
@@ -15,12 +15,10 @@ PKG_LICENSE_FILES:=COPYING COPYING-GPLV2 COPYING-LGPLV3
 PKG_CPE_ID:=cpe:/a:elfutils_project:elfutils
 
 PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
 
 PKG_PROGRAMS:=elflint findtextrel elfcmp unstrip stack elfcompress elfclassify srcfiles
 
 PKG_SUBDIRS := \
-       libgnu \
        config \
        lib \
        libelf \
@@ -36,8 +34,6 @@ PKG_GNULIB_BASE:=libgnu
 
 PKG_GNULIB_ARGS = \
        --dir=$(HOST_BUILD_DIR) \
-       --local-dir=$(STAGING_DIR_HOST)/share/gnulib \
-       --source-base=$(PKG_GNULIB_BASE) \
        --libtool \
        --avoid=reallocarray \
        --import
@@ -74,7 +70,6 @@ ifeq ($(HOST_OS),Darwin)
 endif
 
 HOST_CFLAGS += -Wno-error -fPIC
-HOST_CXXFLAGS += -O2
 
 HOST_CONFIGURE_ARGS += \
        --without-libintl-prefix \
@@ -98,18 +93,8 @@ HOST_CONFIGURE_VARS += \
        ac_cv_search__obstack_free=yes \
        ac_cv_buildid=yes
 
-Hooks/HostConfigure/Pre := Host/Gnulib $(Hooks/HostConfigure/Pre)
-define Host/Gnulib
-       $(STAGING_DIR_HOST)/bin/gnulib-tool $(PKG_GNULIB_ARGS) $(PKG_GNULIB_MODS);
-endef
-
-define Host/Compile
-       $(call Host/Compile/Default,SUBDIRS='$$$$(wildcard $(PKG_SUBDIRS))')
-endef
-
-define Host/Install
-       $(call Host/Compile/Default,install SUBDIRS='$$$$(wildcard $(PKG_SUBDIRS))')
-endef
+Hooks/HostConfigure/Pre := Host/Gnulib/Prepare $(Hooks/HostConfigure/Pre)
+Hooks/HostCompile/Pre := Host/Gnulib/Compile $(Hooks/HostCompile/Pre)
 
 define Host/Uninstall
        -$(call Host/Compile/Default,uninstall)