rockchip: rock 3a: fix image check failed
authorTomas Lara <tl849670@gmail.com>
Sat, 3 Aug 2024 19:16:15 +0000 (19:16 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 8 Aug 2024 20:35:38 +0000 (22:35 +0200)
Fixes the image check failed on system upgrade
  "Image check failed:
   upgrade: Device radxa,rock3a not supported by this image
   upgrade: Supported devices: radxa,rock-3a"

Signed-off-by: Tomas Lara <tl849670@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16064
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/rockchip/image/armv8.mk

index d8d180a214588739e9d2887ebd74a2702ddef10c..c92a8ba4f7f60438dc43f5300bffb82be75fa5ec 100644 (file)
@@ -119,6 +119,7 @@ define Device/radxa_rock-3a
   DEVICE_VENDOR := Radxa
   DEVICE_MODEL := ROCK 3A
   SOC := rk3568
+  SUPPORTED_DEVICES := radxa,rock3a
   DEVICE_PACKAGES := kmod-usb-net-cdc-ncm kmod-usb-net-rndis
 endef
 TARGET_DEVICES += radxa_rock-3a