ramips: mt76x8: Add support for Zbtlink ZBT-WE2426-B
authorVaclav Svoboda <svoboda@neng.cz>
Mon, 11 Nov 2024 21:34:00 +0000 (22:34 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 23 Nov 2024 16:41:39 +0000 (17:41 +0100)
The Zbtlink ZBT-WE2426-B is an indoor dual band WiFi router
with 4 external non detachable antennas and 5 Fast Ethernet ports.

Hardware of ZBT-WE2426-B:
- SoC: MT7628AN
- RAM: 64 MB (Winbond W9751G6K8-25)
- Storage: 8 MB SPI flash (S25FL064K)
- Ethernet: 5x 10/100 Mbps LAN1,LAN2,LAN3,LAN4 & WAN
- Wireless: 2.4GHz: on SoC (802.11b/g/n)
- Wireless: 5GHz: Mediatek MT7612EN (802.11n/ac)
- LEDs: 8x
- Buttons: 1x reset
- USB: 1x 2.0
- MicroSD slot: 1x
- Power: 9 VDC, 1 A
- Uart: GND TX RX PWR - J1 on the PCB
- Board silkscreen: "ZBT-WE2426-C V04" "2018-02-28" "CTT" "13 18"

Backup the stock firmware, settings and calibration data:
This router comes with PandoraBox OpenWrt firmware, so it is
possible to get all MTD partitions using scp.

Installation:
- Using the bootloader web server. Hold the reset button while turning
  the power on. Upload the sysupgrade image on http://192.168.1.1.
- Using the sysupgrade command in PandoraBox OpenWrt.

LEDs:
- LAN1,LAN2,LAN3,LAN4,WAN,WLAN2G use GPIO pins of the MT7628AN SoC
  (GPIOs 43,42,41,40,39,44)
- WLAN5G uses pin of MT7612EN.
- The POWER LED is directly connected to the VCC. It can be reconnected to
  the GPIO 37 of the MT7628AN SoC by resoldering SMD resistor on the PCB.

Buttons:
- The RESET button is connected to the GPIO 38 of the MT7628AN SoC.

MAC addresses as verified by OEM firmware:
use   address   source
2g    *:b0      factory 0x4 (label)
5g    *:b1      factory 0x8004
LAN   *:b2      factory 0x28
WAN   *:b3      factory 0x2e

Signed-off-by: Vaclav Svoboda <svoboda@neng.cz>
Link: https://github.com/openwrt/openwrt/pull/16927
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/ramips/dts/mt7628an_zbtlink_zbt-we2426-b.dts [new file with mode: 0644]
target/linux/ramips/image/mt76x8.mk
target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
target/linux/ramips/mt76x8/base-files/etc/board.d/02_network

diff --git a/target/linux/ramips/dts/mt7628an_zbtlink_zbt-we2426-b.dts b/target/linux/ramips/dts/mt7628an_zbtlink_zbt-we2426-b.dts
new file mode 100644 (file)
index 0000000..6dfdb26
--- /dev/null
@@ -0,0 +1,183 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/leds/common.h>
+
+/ {
+       compatible = "zbtlink,zbt-we2426-b", "mediatek,mt7628an-soc";
+       model = "Zbtlink ZBT-WE2426-B";
+
+       aliases {
+               led-boot = &led_wlan;
+               led-failsafe = &led_wlan;
+               led-upgrade = &led_wlan;
+               label-mac-device = &wmac;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               lan1 {
+                       gpios = <&gpio 43 GPIO_ACTIVE_LOW>;
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_LAN;
+                       function-enumerator = <1>;
+               };
+
+               lan2 {
+                       gpios = <&gpio 42 GPIO_ACTIVE_LOW>;
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_LAN;
+                       function-enumerator = <2>;
+               };
+
+               lan3 {
+                       gpios = <&gpio 41 GPIO_ACTIVE_LOW>;
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_LAN;
+                       function-enumerator = <3>;
+               };
+
+               lan4 {
+                       gpios = <&gpio 40 GPIO_ACTIVE_LOW>;
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_LAN;
+                       function-enumerator = <4>;
+               };
+
+               wan {
+                       gpios = <&gpio 39 GPIO_ACTIVE_LOW>;
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_WAN;
+               };
+
+               led_wlan: wlan2g {
+                       gpios = <&gpio 44 GPIO_ACTIVE_LOW>;
+                       color = <LED_COLOR_ID_GREEN>;
+                       function = LED_FUNCTION_WLAN;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+
+                               nvmem-layout {
+                                       compatible = "fixed-layout";
+                                       #address-cells = <1>;
+                                       #size-cells = <1>;
+
+                                       eeprom_factory_0: eeprom@0 {
+                                               reg = <0x0 0x400>;
+                                       };
+
+                                       eeprom_factory_8000: eeprom@8000 {
+                                               reg = <0x8000 0x200>;
+                                       };
+
+                                       macaddr_factory_28: macaddr@28 {
+                                               reg = <0x28 0x6>;
+                                       };
+                               };
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x50000 0x7b0000>;
+                       };
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "i2s", "refclk", "wdt", "p4led_an",
+                               "p3led_an", "p2led_an",
+                               "p1led_an", "p0led_an",
+                               "wled_an";
+               function = "gpio";
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               nvmem-cells = <&eeprom_factory_8000>;
+               nvmem-cell-names = "eeprom";
+               ieee80211-freq-limit = <5000000 6000000>;
+
+               led {
+                       led-sources = <2>;
+                       led-active-low;
+               };
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       nvmem-cells = <&eeprom_factory_0>;
+       nvmem-cell-names = "eeprom";
+};
+
+&ethernet {
+       nvmem-cells = <&macaddr_factory_28>;
+       nvmem-cell-names = "mac-address";
+};
+
+&esw {
+       mediatek,portmap = <0x2f>;
+};
+
+&sdhci {
+       status = "okay";
+};
index 8ad840ddfead64f5b8a6d076963bd9104ba691e0..7e343bf0164fb05d1d6b9e72afa588736d3d32fa 100644 (file)
@@ -1158,6 +1158,14 @@ define Device/zbtlink_zbt-we1226
 endef
 TARGET_DEVICES += zbtlink_zbt-we1226
 
+define Device/zbtlink_zbt-we2426-b
+  IMAGE_SIZE := 7872k
+  DEVICE_VENDOR := Zbtlink
+  DEVICE_MODEL := ZBT-WE2426-B
+  DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += zbtlink_zbt-we2426-b
+
 define Device/zyxel_keenetic-extra-ii
   IMAGE_SIZE := 29824k
   DEVICE_VENDOR := Zyxel
index 5ea668de0126244a6502ed6170a6f1ac8e430f25..00e5086bb3fea5869b85dfb0316ce8bdb0b0eede 100644 (file)
@@ -186,6 +186,13 @@ zbtlink,zbt-we1226)
        ucidef_set_led_switch "lan2" "LAN2" "green:lan2" "switch0" "0x02"
        ucidef_set_led_switch "wan" "WAN" "green:wan" "switch0" "0x10"
        ;;
+zbtlink,zbt-we2426-b)
+       ucidef_set_led_switch "wan" "wan" "green:wan" "switch0" "0x10"
+       ucidef_set_led_switch "lan1" "lan1" "green:lan-1" "switch0" "0x01"
+       ucidef_set_led_switch "lan2" "lan2" "green:lan-2" "switch0" "0x02"
+       ucidef_set_led_switch "lan3" "lan3" "green:lan-3" "switch0" "0x04"
+       ucidef_set_led_switch "lan4" "lan4" "green:lan-4" "switch0" "0x08"
+       ;;
 zyxel,keenetic-extra-ii)
        ucidef_set_led_netdev "wifi_led" "wifi" "green:wifi" "wlan0"
        ucidef_set_led_switch "internet" "internet" "green:internet" "switch0" "0x01"
index cb0983b9dc133bd5f3b6337723226a1419fd4a33..616baa80c055c72eab4e674b175cf30467aac236 100644 (file)
@@ -148,7 +148,8 @@ ramips_setup_interfaces()
        netgear,r6020|\
        netgear,r6080|\
        netgear,r6120|\
-       wavlink,wl-wn531a3)
+       wavlink,wl-wn531a3|\
+       zbtlink,zbt-we2426-b)
                ucidef_add_switch "switch0" \
                        "0:lan:4" "1:lan:3" "2:lan:2" "3:lan:1" "4:wan" "6@eth0"
                ;;
@@ -244,7 +245,8 @@ ramips_setup_macs()
        hilink,hlk-7688a|\
        wavlink,wl-wn531a3|\
        wavlink,wl-wn577a2|\
-       wavlink,wl-wn578a2)
+       wavlink,wl-wn578a2|\
+       zbtlink,zbt-we2426-b)
                wan_mac=$(mtd_get_mac_binary factory 0x2e)
                label_mac=$(mtd_get_mac_binary factory 0x4)
                ;;