updatedd: hotplug scripts should not be executable
authorOliver Ertl <oliver@ertl-net.net>
Wed, 5 Sep 2007 20:00:13 +0000 (20:00 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Wed, 5 Sep 2007 20:00:13 +0000 (20:00 +0000)
SVN-Revision: 8633

net/updatedd/Makefile

index 145cbf4a798151158b7a2d4124cfdc4566da57d6..12d119dbe6953ec80fbad8ddd129c6727e7aab6a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -121,7 +121,7 @@ define Package/updatedd/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/updatedd $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/updatedd
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_BIN) ./files/updatedd.hotplug $(1)/etc/hotplug.d/iface/30-updatedd
+       $(INSTALL_DATA) ./files/updatedd.hotplug $(1)/etc/hotplug.d/iface/30-updatedd
 endef
 
 $(eval $(call BuildPackage,updatedd))