apk: disable python module
authorChristian Marangi <ansuelsmth@gmail.com>
Sun, 9 Feb 2025 17:40:56 +0000 (18:40 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 18 Feb 2025 14:10:59 +0000 (15:10 +0100)
APK recently introduced python binding support. Disable this sub module
as we don't ship python in normal build to reduce space.

Link: https://github.com/openwrt/openwrt/pull/17925
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/system/apk/Makefile

index c57edb9a87eec8f2e0f36f91c5df40945dbe6d64..b1b1fd3a4028020e2854b1958c73e71dea9693c8 100644 (file)
@@ -61,6 +61,7 @@ MESON_COMMON_ARGS = \
        -Ddefault_library=static \
        -Durl_backend=wget \
        -Dzstd=false \
+       -Dpython=disabled \
        -Dtests=disabled
 
 MESON_HOST_ARGS += \