driver-select: respect disabling b44
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Thu, 8 Oct 2009 23:35:13 +0000 (19:35 -0400)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Thu, 8 Oct 2009 23:35:13 +0000 (19:35 -0400)
This was busted after we started using the drivers/net/Makefile to
select b44, and it was *always* enabled.

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
scripts/admin-update.sh
scripts/driver-select

index 096051c67d63e1953e013f6bfbf48b75636183de..84f58a45c052f68e52fec985c04628c509700e26 100755 (executable)
@@ -149,7 +149,7 @@ done
 # b44 is dependent on ssb, so its has to be rebuilt as well.
 DIR="drivers/net"
 cp $GIT_TREE/$DIR/b44.[ch] $DIR
-echo "obj-m += b44.o" > $DIR/Makefile
+echo "obj-$(CONFIG_B44) += b44.o" > $DIR/Makefile
 
 # Misc
 mkdir -p drivers/misc/eeprom/
index fb0dc63bf3a78ed4dc81fa01b124a328e85dc7e9..b89e9e37548f551cbc60ed8e30f4fc687124f56e 100755 (executable)
@@ -8,6 +8,7 @@ DRIVERS_MAKEFILE="drivers/net/wireless/Makefile"
 ATH_MAKEFILE="drivers/net/wireless/ath/Makefile"
 NET_WIRELESS_MAKEFILE="net/wireless/Makefile"
 EEPROM_MAKEFILE="drivers/misc/eeprom/Makefile"
+DRIVERS_NET="drivers/net/Makefile"
 DRIVERS_NET_USB_MAKEFILE="drivers/net/usb/Makefile"
 SSB_MAKEFILE="drivers/ssb/Makefile"
 
@@ -95,7 +96,8 @@ function disable_lib80211
 }
 
 function disable_b44 {
-       perl -i -ne 'print if ! /CONFIG_B44/ ' Makefile
+       backup_file $DRIVERS_NET
+       perl -i -ne 'print if ! /CONFIG_B44/ ' $DRIVERS_NET
 }
 
 function disable_ssb