projects
/
openwrt
/
staging
/
neocturne.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ce91c85
)
build: add apend-uboot command
author
David Bauer
<mail@david-bauer.net>
Tue, 15 May 2018 17:02:48 +0000
(19:02 +0200)
committer
John Crispin
<john@phrozen.org>
Tue, 22 May 2018 18:34:14 +0000
(20:34 +0200)
This commit adds an append-uboot command to append U-Boot from the
bin-directory.
Signed-off-by: David Bauer <mail@david-bauer.net>
include/image-commands.mk
patch
|
blob
|
history
diff --git
a/include/image-commands.mk
b/include/image-commands.mk
index e0322080e96c0b115fbd2c861e18c180afe12155..395e31f9947cc9e81bd2e01361162ca0c7bb794c 100644
(file)
--- a/
include/image-commands.mk
+++ b/
include/image-commands.mk
@@
-186,6
+186,10
@@
define Build/append-ubi
rm $@.tmp
endef
+define Build/append-uboot
+ dd if=$(UBOOT_PATH) >> $@
+endef
+
define Build/pad-to
dd if=$@ of=$@.new bs=$(1) conv=sync
mv $@.new $@