projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f3dd827
)
Fix kernel crypto modules for >= 2.6.36
author
Michael Büsch
<mb@bu3sch.de>
Sat, 11 Sep 2010 21:42:37 +0000
(21:42 +0000)
committer
Michael Büsch
<mb@bu3sch.de>
Sat, 11 Sep 2010 21:42:37 +0000
(21:42 +0000)
SVN-Revision: 23026
package/kernel/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/crypto.mk
b/package/kernel/modules/crypto.mk
index 9227deb80b9faa0e08bbf6d3786cff1edd146028..1ec540be1b381986b5a46f2dfe3b998f23a35980 100644
(file)
--- a/
package/kernel/modules/crypto.mk
+++ b/
package/kernel/modules/crypto.mk
@@
-22,9
+22,9
@@
SHA256_SUFFIX:=$(CRYPTO_GENERIC)
SHA512_SUFFIX:=$(CRYPTO_GENERIC)
CRYPTO_MODULES = \
-
ALGAPI
=crypto_algapi \
+
$(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),ALGAPI2,ALGAPI)
=crypto_algapi \
AEAD2=aead \
-
PCOMP
=pcompress \
+
$(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)),PCOMP2,PCOMP)
=pcompress \
BLKCIPHER2=crypto_blkcipher \
HASH2=crypto_hash \
MANAGER2=cryptomgr \