openssl: update download mirrors
authorChukun Pan <amadeus@jmu.edu.cn>
Wed, 18 Sep 2024 15:10:16 +0000 (23:10 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 25 Sep 2024 21:30:22 +0000 (23:30 +0200)
New releases of openssl are only published on GitHub, and official
downloads are also redirected to GitHub. So remove the old download
mirrors (file 404), and replace the current address with https.

Link: https://openssl-library.org/source/
Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
Link: https://github.com/openwrt/openwrt/pull/16470
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/libs/openssl/Makefile

index 554cde7a2de481af882153349abb7b27adc6b31b..959424ce12c540e18a71a0e23dbd430bccb1c540 100644 (file)
@@ -17,13 +17,9 @@ PKG_BUILD_PARALLEL:=1
 PKG_BASE:=$(subst $(space),.,$(wordlist 1,2,$(subst .,$(space),$(PKG_VERSION))))
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
-       http://www.openssl.org/source/ \
-       http://www.openssl.org/source/old/$(PKG_BASE)/ \
-       https://github.com/openssl/openssl/releases/download/$(PKG_NAME)-$(PKG_VERSION)/ \
-       http://ftp.fi.muni.cz/pub/openssl/source/ \
-       http://ftp.fi.muni.cz/pub/openssl/source/old/$(PKG_BASE)/ \
-       ftp://ftp.pca.dfn.de/pub/tools/net/openssl/source/ \
-       ftp://ftp.pca.dfn.de/pub/tools/net/openssl/source/old/$(PKG_BASE)/
+       https://www.openssl.org/source/ \
+       https://www.openssl.org/source/old/$(PKG_BASE)/ \
+       https://github.com/openssl/openssl/releases/download/$(PKG_NAME)-$(PKG_VERSION)/
 
 PKG_HASH:=23c666d0edf20f14249b3d8f0368acaee9ab585b09e1de82107c66e1f3ec9533
 
@@ -74,7 +70,7 @@ endif
 
 define Package/openssl/Default
   TITLE:=Open source SSL toolkit
-  URL:=http://www.openssl.org/
+  URL:=https://www.openssl.org/
   SECTION:=libs
   CATEGORY:=Libraries
 endef