projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
e44384c
)
fix kconfig for packages that only define =y, =m or =n rules
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 27 Aug 2008 21:34:01 +0000
(21:34 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 27 Aug 2008 21:34:01 +0000
(21:34 +0000)
SVN-Revision: 12414
include/kernel.mk
patch
|
blob
|
history
diff --git
a/include/kernel.mk
b/include/kernel.mk
index 7d986e4597ebbe0fd09c443fa58abebd0d50e5f4..8393d2f4209be060a3e8c45a7eb391b560b1bc53 100644
(file)
--- a/
include/kernel.mk
+++ b/
include/kernel.mk
@@
-126,7
+126,7
@@
$(call KernelPackage/$(1)/config)
endef
endif
- ifneq ($(if $(
KCONFIG
),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
+ ifneq ($(if $(
filter-out %=y %=n %=m,$(KCONFIG)
),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
ifneq ($(strip $(FILES)),)
define Package/kmod-$(1)/install
mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)