projects
/
openwrt
/
staging
/
xback.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
8953946
)
package/kernel: only include i2c-of if CONFIG_OF enabled
author
Gabor Juhos
<juhosg@openwrt.org>
Sat, 6 Apr 2013 16:55:25 +0000
(16:55 +0000)
committer
Gabor Juhos
<juhosg@openwrt.org>
Sat, 6 Apr 2013 16:55:25 +0000
(16:55 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 36227
package/kernel/modules/i2c.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/i2c.mk
b/package/kernel/modules/i2c.mk
index 5cf929de97b9c2c747d8c829659840572d748d5d..085570836f6326d8e7592dfea40c9fa4cd4a25d2 100644
(file)
--- a/
package/kernel/modules/i2c.mk
+++ b/
package/kernel/modules/i2c.mk
@@
-22,9
+22,12
@@
endef
I2C_CORE_MODULES:= \
CONFIG_I2C:drivers/i2c/i2c-core \
- CONFIG_OF_I2C:drivers/of/of_i2c \
CONFIG_I2C_CHARDEV:drivers/i2c/i2c-dev
+ifeq (CONFIG_OF,y)
+ I2C_CORE_MODULES+=CONFIG_OF_I2C:drivers/of/of_i2c
+endif
+
define KernelPackage/i2c-core
$(call i2c_defaults,$(I2C_CORE_MODULES),51)
TITLE:=I2C support