compat-drivers: Copy core/ subdir of nouveau driver
authorOzan Çağlayan <ozancag@gmail.com>
Sat, 27 Oct 2012 14:22:03 +0000 (17:22 +0300)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Sat, 27 Oct 2012 15:03:32 +0000 (08:03 -0700)
This was introduced with the latest nouveau code rewrite. Copy
this directory too.

Signed-off-by: Ozan Çağlayan <ozancag@gmail.com>
Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
scripts/admin-update.sh

index e94f9bdd480fb653a90ffb97d88293d9e02229e7..68a5b27830338dc0e3b3fd7fa687a81fa0ac9bc3 100755 (executable)
@@ -537,6 +537,9 @@ if [[ "$ENABLE_DRM" == "1" ]]; then
        # Copy radeon reg_srcs for hostprogs
        cp -a $GIT_TREE/drivers/gpu/drm/radeon/reg_srcs drivers/gpu/drm/radeon
 
+       # Copy core/ from nouveau/ (Introduced after new code rewrite in 3.7)
+       cp -a $GIT_TREE/drivers/gpu/drm/nouveau/core drivers/gpu/drm/nouveau
+
        # Finally get the DRM top-level makefile
        cp $GIT_TREE/drivers/gpu/drm/Makefile drivers/gpu/drm
 else