ppp: update to 2.5.2
authorShiji Yang <yangshiji66@qq.com>
Sat, 4 Jan 2025 07:59:57 +0000 (15:59 +0800)
committerNick Hainke <vincent@systemli.org>
Sun, 5 Jan 2025 21:50:20 +0000 (22:50 +0100)
This is a minor upgrade that mainly fixes some compilation errors
and remove old unused code.

The Makefile has been reorganized. Now all package make parameters
are passed as configure arguments instead of environment variables.
The compilation dependencies remain the same as ppp v2.5.1 and the
package size changes are negligible.

Change log:
https://github.com/ppp-project/ppp/blob/v2.5.2/README#L70

Upstreamed patches:
101-pppd-crypto-fix-build-without-openssl.patch [1]
102-pppd-make-pid-directory-before-create-the-pid-file.patch [2]
103-pppd-crypto-fix-gcc-14-build.patch [3]

[1] https://github.com/ppp-project/ppp/commit/5f6eabdb6666d914e0f8feb3facfa591dee75a1f
[2] https://github.com/ppp-project/ppp/commit/734bc0438e78b7c7cd34acfce3a4ec119d9a50b6
[3] https://github.com/ppp-project/ppp/commit/ac269dbf7c142371cd975c775c6171707ac4dde8

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Link: https://github.com/openwrt/openwrt/pull/17477
Signed-off-by: Nick Hainke <vincent@systemli.org>
14 files changed:
package/network/services/ppp/Makefile
package/network/services/ppp/patches/101-pppd-crypto-fix-build-without-openssl.patch [deleted file]
package/network/services/ppp/patches/102-pppd-make-pid-directory-before-create-the-pid-file.patch [deleted file]
package/network/services/ppp/patches/103-pppd-crypto-fix-gcc-14-build.patch [deleted file]
package/network/services/ppp/patches/105-debian_demand.patch
package/network/services/ppp/patches/204-radius_config.patch
package/network/services/ppp/patches/208-fix_status_code.patch
package/network/services/ppp/patches/310-precompile_filter.patch
package/network/services/ppp/patches/321-multilink_support_custom_iface_names.patch
package/network/services/ppp/patches/340-populate_default_gateway.patch
package/network/services/ppp/patches/400-simplify_kernel_checks.patch
package/network/services/ppp/patches/401-no_record_file.patch
package/network/services/ppp/patches/404-remove_obsolete_protocol_names.patch
package/network/services/ppp/patches/500-add-pptp-plugin.patch

index 760a31dc0d02da617c8cc33501a8a9945adfc5a8..ceb32c397801fbf70f6174b434e855cd07eb6b47 100644 (file)
@@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
-PKG_VERSION:=2.5.1
+PKG_VERSION:=2.5.2
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/ppp-project/ppp
-PKG_SOURCE_DATE:=2024-09-18
-PKG_SOURCE_VERSION:=d5aeec65752d4a9b3bb46771d0b221c4a4a6539e
-PKG_MIRROR_HASH:=b98125933d8160ff3476b053414e787e65a94948c0ecee53f6261cd403ff4b03
+PKG_SOURCE_DATE:=2024-12-31
+PKG_SOURCE_VERSION:=9f612dc02c34509f062ed63b60bcc7e937e25178
+PKG_MIRROR_HASH:=677b71d23b668db986146e13b0c651f2ac506eb4fb244ffba1ff406cbae3511b
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_LICENSE:=BSD-4-Clause
@@ -30,17 +30,22 @@ PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
-CONFIGURE_VARS += \
-       enable_eaptls=no \
-       enable_microsoft_extensions=yes \
-       enable_peap=no
-
 CONFIGURE_ARGS += \
-       with_openssl=no \
-       with_pam=no \
-       with_pcap=no \
-       with_srp=no \
-       with_static_pcap=yes
+       --disable-cbcp \
+       --disable-eaptls \
+       --disable-mslanman \
+       --disable-openssl-engine \
+       --disable-peap \
+       --disable-systemd \
+       --enable-ipv6cp \
+       --enable-microsoft-extensions \
+       --enable-plugins \
+       --with-atm \
+       --with-static-pcap \
+       --without-openssl \
+       --without-pam \
+       --without-pcap \
+       --without-srp
 
 define Package/ppp/Default
   SECTION:=net
@@ -185,8 +190,8 @@ not initiate a session. Can be useful to debug pppoe.
 endef
 
 ifeq ($(BUILD_VARIANT),multilink)
-  CONFIGURE_VARS += \
-       enable_multilink=yes
+  CONFIGURE_ARGS += \
+       --enable-multilink
 endif
 
 define Build/InstallDev
diff --git a/package/network/services/ppp/patches/101-pppd-crypto-fix-build-without-openssl.patch b/package/network/services/ppp/patches/101-pppd-crypto-fix-build-without-openssl.patch
deleted file mode 100644 (file)
index eb24369..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-From: Shiji Yang <yangshiji66@outlook.com>
-Date: Fri, 4 Oct 2024 12:19:42 +0000
-Subject: [PATCH] pppd/crypto: fix build without openssl
-
-Compile openssl relevant code only when PPP_WITH_OPENSSL is defined.
-
-Signed-off-by: Shiji Yang <yangshiji66@outlook.com>
----
- pppd/crypto.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
---- a/pppd/crypto.c
-+++ b/pppd/crypto.c
-@@ -199,6 +199,7 @@ int PPP_crypto_init()
- {
-     int retval = 0;
-+#ifdef PPP_WITH_OPENSSL
- #if OPENSSL_VERSION_NUMBER >= 0x30000000L
-     g_crypto_ctx.legacy = OSSL_PROVIDER_load(NULL, "legacy");
-     if (g_crypto_ctx.legacy == NULL)
-@@ -214,6 +215,7 @@ int PPP_crypto_init()
-         goto done;
-     }
- #endif
-+#endif
-     retval = 1;
-@@ -224,6 +226,7 @@ done:
- int PPP_crypto_deinit()
- {
-+#ifdef PPP_WITH_OPENSSL
- #if OPENSSL_VERSION_NUMBER >= 0x30000000L
-     if (g_crypto_ctx.legacy) {
-         OSSL_PROVIDER_unload(g_crypto_ctx.legacy);
-@@ -239,6 +242,7 @@ int PPP_crypto_deinit()
- #if OPENSSL_VERSION_NUMBER < 0x10100000L
-     ERR_free_strings();
- #endif
-+#endif
-     return 1;
- }
diff --git a/package/network/services/ppp/patches/102-pppd-make-pid-directory-before-create-the-pid-file.patch b/package/network/services/ppp/patches/102-pppd-make-pid-directory-before-create-the-pid-file.patch
deleted file mode 100644 (file)
index 69e68cd..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-From: Shiji Yang <yangshiji66@outlook.com>
-Date: Fri, 4 Oct 2024 14:02:14 +0000
-Subject: [PATCH] pppd: make pid directory before create the pid file
-
-If multilink feature is not enabled, the '/var/run/pppd' directory
-won't be created before adding pid file.
-
-Fixes error message:
-'Failed to create pid file /var/run/pppd/pppoe-wan.pid: No such file or directory'
-
-Signed-off-by: Shiji Yang <yangshiji66@outlook.com>
----
- pppd/main.c | 3 +++
- 1 file changed, 3 insertions(+)
-
---- a/pppd/main.c
-+++ b/pppd/main.c
-@@ -921,6 +921,9 @@ create_pidfile(int pid)
- {
-     FILE *pidfile;
-+#ifndef PPP_WITH_TDB
-+    mkdir_recursive(PPP_PATH_VARRUN);
-+#endif
-     slprintf(pidfilename, sizeof(pidfilename), "%s/%s.pid",
-            PPP_PATH_VARRUN, ifname);
-     if ((pidfile = fopen(pidfilename, "w")) != NULL) {
diff --git a/package/network/services/ppp/patches/103-pppd-crypto-fix-gcc-14-build.patch b/package/network/services/ppp/patches/103-pppd-crypto-fix-gcc-14-build.patch
deleted file mode 100644 (file)
index 3a76deb..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-From: Tan Zien <nabsdh9@gmail.com>
-Date: Tue, 1 Oct 2024 10:38:45 +0800
-Subject: [PATCH] pppd/crypto: fix gcc 14 build
-
-fix this:
-
-crypto.c: In function 'PPP_crypto_error':
-crypto.c:178:11: error: implicit declaration of function 'vsnprintf' [-Wimplicit-function-declaration]
-  178 |     off = vsnprintf(buf, len, fmt, args);
-      |           ^~~~~~~~~
-crypto.c:41:1: note: include '<stdio.h>' or provide a declaration of 'vsnprintf'
-   40 | #include "crypto-priv.h"
-  +++ |+#include <stdio.h>
-   41 |
-crypto.c:178:26: warning: 'vsnprintf' argument 2 type is 'int' where 'long unsigned int' is expected in a call to built-in function declared without prototype [-Wbuiltin-declaration-mismatch]
-  178 |     off = vsnprintf(buf, len, fmt, args);
-      |                          ^~~
-<built-in>: note: built-in 'vsnprintf' declared here
-
-Signed-off-by: Tan Zien <nabsdh9@gmail.com>
----
- pppd/crypto.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/pppd/crypto.c
-+++ b/pppd/crypto.c
-@@ -34,6 +34,7 @@
- #include <stdlib.h>
- #include <string.h>
-+#include <stdio.h>
- #include "pppd.h"
- #include "crypto.h"
-@@ -247,7 +248,6 @@ int PPP_crypto_deinit()
- }
- #ifdef UNIT_TEST
--#include <stdio.h>
- int debug;
- int error_count;
index 10ce13b25355f4a5db457a8e6b2bafcdabc4a6e9..25f1644aa4b367baedfc4c7d31113ac774fe366c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/pppd/demand.c
 +++ b/pppd/demand.c
-@@ -40,6 +40,8 @@
+@@ -34,6 +34,8 @@
  #include <errno.h>
  #include <fcntl.h>
  #include <netdb.h>
@@ -9,7 +9,7 @@
  #include <sys/param.h>
  #include <sys/types.h>
  #include <sys/wait.h>
-@@ -47,6 +49,8 @@
+@@ -41,6 +43,8 @@
  #include <sys/resource.h>
  #include <sys/stat.h>
  #include <sys/socket.h>
@@ -18,7 +18,7 @@
  #ifdef PPP_WITH_FILTER
  #include <pcap-bpf.h>
  #endif
-@@ -223,6 +227,14 @@ loop_chars(unsigned char *p, int n)
+@@ -217,6 +221,14 @@ loop_chars(unsigned char *p, int n)
      int c, rv;
  
      rv = 0;
@@ -33,7 +33,7 @@
      for (; n > 0; --n) {
        c = *p++;
        if (c == PPP_FLAG) {
-@@ -299,16 +311,100 @@ loop_frame(unsigned char *frame, int len
+@@ -293,16 +305,100 @@ loop_frame(unsigned char *frame, int len
   * loopback, now that the real serial link is up.
   */
  void
      } else {
 --- a/pppd/pppd-private.h
 +++ b/pppd/pppd-private.h
-@@ -368,7 +368,7 @@ void demand_conf(void);    /* config interf
+@@ -370,7 +370,7 @@ void demand_conf(void);    /* config interf
  void demand_block(void);      /* set all NPs to queue up packets */
  void demand_unblock(void); /* set all NPs to pass packets */
  void demand_discard(void); /* set all NPs to discard packets */
index 3f6db59b710f248caaf32c4eb8b0c76e0f46de21..1f5fdffa9566e974686b2003e344ca121bf589b8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/pppd/plugins/radius/config.c
 +++ b/pppd/plugins/radius/config.c
-@@ -381,31 +381,37 @@ static int test_config(char *filename)
+@@ -379,31 +379,37 @@ static int test_config(char *filename)
        }
  #endif
  
@@ -40,7 +40,7 @@
  }
 --- a/pppd/plugins/radius/options.h
 +++ b/pppd/plugins/radius/options.h
-@@ -31,24 +31,21 @@ typedef struct _option {
+@@ -29,24 +29,21 @@ typedef struct _option {
  static SERVER acctserver = {0};
  static SERVER authserver = {0};
  
index 10cd94537421ae58bbe470733b057ae8330c792d..2d1e02742e30b3ce635def60146c1aa48cdd1df6 100644 (file)
@@ -12,13 +12,13 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
 
 --- a/pppd/main.c
 +++ b/pppd/main.c
-@@ -1152,7 +1152,8 @@ get_input(void)
+@@ -1150,7 +1150,8 @@ get_input(void)
        }
        notice("Modem hangup");
        hungup = 1;
 -      code = EXIT_HANGUP;
 +      if (code == EXIT_OK)
 +              code = EXIT_HANGUP;
+       need_holdoff = 0;
        lcp_lowerdown(0);       /* serial link is no longer available */
        link_terminated(0);
-       return;
index ad0dd03de8e1eaf4b13c3c2a5ec3066f081b3a3a..6a6d276979656334049d2487750faea81de4a92e 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
  #
  # SunOS provides a version of libpcap that would work, but SunOS has no support for activity filter
  AM_CONDITIONAL([PPP_WITH_FILTER], [ test "x${with_pcap}" = "xyes" && test "x${build_sunos}" != "xyes" ])
-@@ -359,6 +362,7 @@ $PACKAGE_NAME version $PACKAGE_VERSION
+@@ -348,6 +351,7 @@ $PACKAGE_NAME version $PACKAGE_VERSION
      With libatm..........: ${with_atm:-no}
      With libpam..........: ${with_pam:-no}
      With libpcap.........: ${with_pcap:-no}
@@ -33,7 +33,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
      Linker...............: $LD $LDFLAGS $LIBS
 --- a/pppd/Makefile.am
 +++ b/pppd/Makefile.am
-@@ -138,6 +138,12 @@ pppd_LDFLAGS += $(PCAP_LDFLAGS)
+@@ -137,6 +137,12 @@ pppd_LDFLAGS += $(PCAP_LDFLAGS)
  pppd_LIBS += $(PCAP_LIBS)
  endif
  
index a761ca650d6cb027f4ccdb7183eca551f47a4eb1..2070ab7d09199c87ed96a62f4f91841cc0333a92 100644 (file)
@@ -8,7 +8,7 @@ Signed-off-by: George Kashperko <george@znau.edu.ua>
  2 files changed, 53 insertions(+), 14 deletions(-)
 --- a/pppd/multilink.c
 +++ b/pppd/multilink.c
-@@ -40,6 +40,7 @@
+@@ -36,6 +36,7 @@
  #include <signal.h>
  #include <netinet/in.h>
  #include <unistd.h>
@@ -16,7 +16,7 @@ Signed-off-by: George Kashperko <george@znau.edu.ua>
  
  #include "pppd-private.h"
  #include "fsm.h"
-@@ -62,7 +63,8 @@ static void iterate_bundle_links(void (*
+@@ -58,7 +59,8 @@ static void iterate_bundle_links(void (*
  
  static int get_default_epdisc(struct epdisc *);
  static int parse_num(char *str, const char *key, int *valp);
@@ -26,7 +26,7 @@ Signed-off-by: George Kashperko <george@znau.edu.ua>
  
  #define set_ip_epdisc(ep, addr) do {  \
        ep->length = 4;                 \
-@@ -215,35 +217,38 @@ mp_join_bundle(void)
+@@ -211,35 +213,38 @@ mp_join_bundle(void)
        key.dptr = bundle_id;
        key.dsize = p - bundle_id;
        pid = tdb_fetch(pppdb, key);
@@ -73,7 +73,7 @@ Signed-off-by: George Kashperko <george@znau.edu.ua>
        }
  
        /* we have to make a new bundle */
-@@ -423,20 +428,39 @@ parse_num(char *str, const char *key, in
+@@ -419,20 +424,39 @@ parse_num(char *str, const char *key, in
        return 0;
  }
  
@@ -119,7 +119,7 @@ Signed-off-by: George Kashperko <george@znau.edu.ua>
                        && memcmp(vd.dptr, key.dptr, vd.dsize) == 0;
 --- a/pppd/sys-linux.c
 +++ b/pppd/sys-linux.c
-@@ -984,6 +984,16 @@ void cfg_bundle(int mrru, int mtru, int
+@@ -980,6 +980,16 @@ void cfg_bundle(int mrru, int mtru, int
        add_fd(ppp_dev_fd);
  }
  
@@ -136,7 +136,7 @@ Signed-off-by: George Kashperko <george@znau.edu.ua>
  /*
   * make_new_bundle - create a new PPP unit (i.e. a bundle)
   * and connect our channel to it.  This should only get called
-@@ -1002,6 +1012,8 @@ void make_new_bundle(int mrru, int mtru,
+@@ -998,6 +1008,8 @@ void make_new_bundle(int mrru, int mtru,
  
        /* set the mrru and flags */
        cfg_bundle(mrru, mtru, rssn, tssn);
index f3279713469d383461ed87b2e0eda7944e8627ee..7d20f0449d7f39a6d411501c5a2553d6a3901b2f 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
 
 --- a/pppd/sys-linux.c
 +++ b/pppd/sys-linux.c
-@@ -2251,6 +2251,9 @@ int sifdefaultroute (int unit, u_int32_t
+@@ -2247,6 +2247,9 @@ int sifdefaultroute (int unit, u_int32_t
      memset (&rt, 0, sizeof (rt));
      SET_SA_FAMILY (rt.rt_dst, AF_INET);
  
@@ -23,7 +23,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
      rt.rt_dev = ifname;
      rt.rt_metric = dfl_route_metric + 1; /* +1 for binary compatibility */
  
-@@ -2259,7 +2262,7 @@ int sifdefaultroute (int unit, u_int32_t
+@@ -2255,7 +2258,7 @@ int sifdefaultroute (int unit, u_int32_t
        SIN_ADDR(rt.rt_genmask) = 0L;
      }
  
index 311bb8752f9d4441d5643a7f1172d5da45082e67..014831a3a4259548901af93b1dfa1193ce53f90c 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
 
 --- a/pppd/sys-linux.c
 +++ b/pppd/sys-linux.c
-@@ -224,14 +224,10 @@ static fd_set in_fds;            /* set of fds tha
+@@ -220,14 +220,10 @@ static fd_set in_fds;            /* set of fds tha
  static int max_in_fd;         /* highest fd set in in_fds */
  
  static int has_proxy_arp       = 0;
@@ -26,7 +26,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
  
  static char loop_name[20];
  static unsigned char inbuf[512]; /* buffer for chars read from loopback */
-@@ -249,9 +245,8 @@ static int dynaddr_set;            /* 1 if ip_dyna
+@@ -245,9 +241,8 @@ static int dynaddr_set;            /* 1 if ip_dyna
  static int    looped;                 /* 1 if using loop */
  static int    link_mtu;               /* mtu for the link (not bundle) */
  
@@ -37,7 +37,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
  
  #define MAX_IFS               100
  
-@@ -1970,11 +1965,12 @@ int ccp_fatal_error (int unit)
+@@ -1966,11 +1961,12 @@ int ccp_fatal_error (int unit)
   *
   * path_to_procfs - find the path to the proc file system mount point
   */
@@ -52,7 +52,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
      struct mntent *mntent;
      FILE *fp;
  
-@@ -1996,6 +1992,7 @@ static char *path_to_procfs(const char *
+@@ -1992,6 +1988,7 @@ static char *path_to_procfs(const char *
            fclose (fp);
        }
      }
@@ -60,7 +60,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
  
      strlcpy(proc_path + proc_path_len, tail,
            sizeof(proc_path) - proc_path_len);
-@@ -2889,6 +2886,8 @@ ppp_registered(void)
+@@ -2883,6 +2880,8 @@ ppp_registered(void)
  
  int ppp_check_kernel_support(void)
  {
@@ -69,7 +69,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
      int s, ok, fd;
      struct ifreq ifr;
      int    size;
-@@ -3016,6 +3015,7 @@ int ppp_check_kernel_support(void)
+@@ -3010,6 +3009,7 @@ int ppp_check_kernel_support(void)
      }
      close(s);
      return ok;
@@ -77,7 +77,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
  }
  
  #ifndef HAVE_LOGWTMP
-@@ -3577,6 +3577,7 @@ get_pty(int *master_fdp, int *slave_fdp,
+@@ -3571,6 +3571,7 @@ get_pty(int *master_fdp, int *slave_fdp,
      }
  #endif /* TIOCGPTN */
  
@@ -85,7 +85,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
      if (sfd < 0) {
        /* the old way - scan through the pty name space */
        for (i = 0; i < 64; ++i) {
-@@ -3601,6 +3602,7 @@ get_pty(int *master_fdp, int *slave_fdp,
+@@ -3595,6 +3596,7 @@ get_pty(int *master_fdp, int *slave_fdp,
            }
        }
      }
@@ -93,7 +93,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
  
      if (sfd < 0)
        return 0;
-@@ -3716,6 +3718,7 @@ get_host_seed(void)
+@@ -3710,6 +3712,7 @@ get_host_seed(void)
  int
  sys_check_options(void)
  {
@@ -101,7 +101,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
      if (demand && driver_is_old) {
        ppp_option_error("demand dialling is not supported by kernel driver "
                     "version %d.%d.%d", driver_version, driver_modification,
-@@ -3726,6 +3729,7 @@ sys_check_options(void)
+@@ -3720,6 +3723,7 @@ sys_check_options(void)
        warn("Warning: multilink is not supported by the kernel driver");
        multilink = 0;
      }
@@ -124,7 +124,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
  #endif
 --- a/pppd/plugins/pppoe/plugin.c
 +++ b/pppd/plugins/pppoe/plugin.c
-@@ -57,9 +57,6 @@ static char const RCSID[] =
+@@ -54,9 +54,6 @@
  
  char pppd_version[] = PPPD_VERSION;
  
@@ -134,7 +134,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
  char *pppd_pppoe_service = NULL;
  static char *acName = NULL;
  static char *existingSession = NULL;
-@@ -421,10 +418,6 @@ PPPoEDevnameHook(char *cmd, char **argv,
+@@ -418,10 +415,6 @@ PPPoEDevnameHook(char *cmd, char **argv,
  void
  plugin_init(void)
  {
index 5ef1a178d704aab48010710add086f65c5ec2557..436bfb5f5ea13630d8f4ae98f104acc0082a1d91 100644 (file)
@@ -7,7 +7,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
 
 --- a/pppd/pppd-private.h
 +++ b/pppd/pppd-private.h
-@@ -187,7 +187,6 @@ extern int holdoff;        /* Dead time before
+@@ -189,7 +189,6 @@ extern int holdoff;        /* Dead time before
  extern bool   holdoff_specified; /* true if user gave a holdoff value */
  extern bool   notty;          /* Stdin/out is not a tty */
  extern char   *pty_socket;    /* Socket to connect to pty */
@@ -17,7 +17,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
  extern bool   tune_kernel;    /* May alter kernel settings as necessary */
 --- a/pppd/tty.c
 +++ b/pppd/tty.c
-@@ -150,7 +150,7 @@ char       *disconnect_script = NULL; /* Scrip
+@@ -146,7 +146,7 @@ char       *disconnect_script = NULL; /* Scrip
  char  *welcomer = NULL;       /* Script to run after phys link estab. */
  char  *ptycommand = NULL;     /* Command to run on other side of pty */
  bool  notty = 0;              /* Stdin/out is not a tty */
@@ -26,7 +26,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
  int   max_data_rate;          /* max bytes/sec through charshunt */
  bool  sync_serial = 0;        /* Device is synchronous serial device */
  char  *pty_socket = NULL;     /* Socket to connect to pty */
-@@ -206,8 +206,10 @@ static struct option tty_options[] = {
+@@ -202,8 +202,10 @@ static struct option tty_options[] = {
        "Send and receive over socket, arg is host:port",
        OPT_PRIO | OPT_DEVNAM },
  
index 6b2d15ed256f915988aa52153887901dca08c815..5738118c5f7e9fe6201d46099138b012d76bb9b5 100644 (file)
@@ -7,7 +7,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
 
 --- a/pppd/main.c
 +++ b/pppd/main.c
-@@ -984,14 +984,17 @@ struct protocol_list {
+@@ -982,14 +982,17 @@ struct protocol_list {
      const char        *name;
  } protocol_list[] = {
      { 0x21,   "IP" },
@@ -25,7 +25,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
      { 0x33,   "Stream Protocol ST-II" },
      { 0x35,   "Banyan Vines" },
      { 0x39,   "AppleTalk EDDP" },
-@@ -1005,8 +1008,11 @@ struct protocol_list {
+@@ -1003,8 +1006,11 @@ struct protocol_list {
      { 0x49,   "Serial Data Transport Protocol (PPP-SDTP)" },
      { 0x4b,   "SNA over 802.2" },
      { 0x4d,   "SNA" },
@@ -37,7 +37,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
      { 0x53,   "Encryption" },
      { 0x55,   "Individual Link Encryption" },
      { 0x57,   "IPv6" },
-@@ -1017,12 +1023,15 @@ struct protocol_list {
+@@ -1015,12 +1021,15 @@ struct protocol_list {
      { 0x65,   "RTP IPHC Compressed non-TCP" },
      { 0x67,   "RTP IPHC Compressed UDP 8" },
      { 0x69,   "RTP IPHC Compressed RTP 8" },
@@ -53,7 +53,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
      { 0x0203, "IBM Source Routing BPDU" },
      { 0x0205, "DEC LANBridge100 Spanning Tree" },
      { 0x0207, "Cisco Discovery Protocol" },
-@@ -1034,15 +1043,19 @@ struct protocol_list {
+@@ -1032,15 +1041,19 @@ struct protocol_list {
      { 0x0231, "Luxcom" },
      { 0x0233, "Sigma Network Systems" },
      { 0x0235, "Apple Client Server Protocol" },
@@ -73,7 +73,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
      { 0x4001, "Cray Communications Control Protocol" },
      { 0x4003, "CDPD Mobile Network Registration Protocol" },
      { 0x4005, "Expand accelerator protocol" },
-@@ -1053,8 +1066,10 @@ struct protocol_list {
+@@ -1051,8 +1064,10 @@ struct protocol_list {
      { 0x4023, "RefTek Protocol" },
      { 0x4025, "Fibre Channel" },
      { 0x4027, "EMIT Protocols" },
@@ -84,7 +84,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
      { 0x8023, "OSI Network Layer Control Protocol" },
      { 0x8025, "Xerox NS IDP Control Protocol" },
      { 0x8027, "DECnet Phase IV Control Protocol" },
-@@ -1063,7 +1078,9 @@ struct protocol_list {
+@@ -1061,7 +1076,9 @@ struct protocol_list {
      { 0x8031, "Bridging NCP" },
      { 0x8033, "Stream Protocol Control Protocol" },
      { 0x8035, "Banyan Vines Control Protocol" },
@@ -94,7 +94,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
      { 0x803f, "NETBIOS Framing Control Protocol" },
      { 0x8041, "Cisco Systems Control Protocol" },
      { 0x8043, "Ascom Timeplex" },
-@@ -1072,18 +1089,24 @@ struct protocol_list {
+@@ -1070,18 +1087,24 @@ struct protocol_list {
      { 0x8049, "Serial Data Control Protocol (PPP-SDCP)" },
      { 0x804b, "SNA over 802.2 Control Protocol" },
      { 0x804d, "SNA Control Protocol" },
@@ -119,7 +119,7 @@ Signed-off-by: Jo-Philipp Wich <jo@mein.io>
      { 0x8207, "Cisco Discovery Protocol Control" },
      { 0x8209, "Netcs Twin Routing" },
      { 0x820b, "STP - Control Protocol" },
-@@ -1092,24 +1115,29 @@ struct protocol_list {
+@@ -1090,24 +1113,29 @@ struct protocol_list {
      { 0x8281, "MPLSCP" },
      { 0x8285, "IEEE p1284.4 standard - Protocol Control" },
      { 0x8287, "ETSI TETRA TNP1 Control Protocol" },
index 4b66cd216572dff850092ff8ab94922277fe54f9..38b0c82506584a17eabbc2276d5ea3b3fbec8f8b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -344,6 +344,7 @@ AC_CONFIG_FILES([
+@@ -333,6 +333,7 @@ AC_CONFIG_FILES([
      pppd/plugins/pppoatm/Makefile
      pppd/plugins/pppol2tp/Makefile
      pppd/plugins/radius/Makefile
@@ -10,7 +10,7 @@
      scripts/Makefile
 --- a/pppd/plugins/Makefile.am
 +++ b/pppd/plugins/Makefile.am
-@@ -21,5 +21,5 @@ winbind_la_LDFLAGS = $(PLUGIN_LDFLAGS)
+@@ -17,5 +17,5 @@ winbind_la_LDFLAGS = $(PLUGIN_LDFLAGS)
  winbind_la_SOURCES = winbind.c
  
  if !SUNOS