kernel: modules: usb: remove deprecated Kconfig option CONFIG_USB_XHCI_HCD_DEBUGGING
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 31 Jul 2024 06:34:41 +0000 (08:34 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 31 Aug 2024 17:28:04 +0000 (19:28 +0200)
The Kconfig option 'CONFIG_USB_XHCI_HCD_DEBUGGING' has been removed with the
following commit upstream in the Linux kernel.

https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=b2497509df002e9a09c8550cd0ecd2f77c9640d8

This Kconfig option is therefore no longer valid for the kernel version
6.6 and could be removed.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
package/kernel/linux/modules/usb.mk

index 12725f10ee25d9ba83e67763f0c41a338aac5542..b0037378342149275571d3e836c44a439a145bc5 100644 (file)
@@ -1846,9 +1846,7 @@ $(eval $(call KernelPackage,usb-roles))
 
 define KernelPackage/usb-xhci-hcd
   TITLE:=xHCI HCD (USB 3.0) support
-  KCONFIG:= \
-         CONFIG_USB_XHCI_HCD \
-         CONFIG_USB_XHCI_HCD_DEBUGGING=n
+  KCONFIG:= CONFIG_USB_XHCI_HCD
   HIDDEN:=1
   FILES:=$(LINUX_DIR)/drivers/usb/host/xhci-hcd.ko
   AUTOLOAD:=$(call AutoLoad,54,xhci-hcd,1)