compat-wireless: CONFIG_BT_L2CAP and CONFIG_BT_SCO removed
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 22 Dec 2011 20:47:27 +0000 (21:47 +0100)
committerLuis R. Rodriguez <mcgrof@frijolero.org>
Fri, 23 Dec 2011 15:06:53 +0000 (07:06 -0800)
The config options CONFIG_BT_L2CAP and CONFIG_BT_SCO were removed from
the kernel and this patch removes them from compat-wireless.

commit f1e91e1640d808d332498a6b09b2bcd01462eff9
Author: Ulisses Furquim <ulisses@profusion.mobi>
Date:   Wed Dec 21 01:32:09 2011 -0200

    Bluetooth: Always compile SCO and L2CAP in Bluetooth Core

    The handling of SCO audio links and the L2CAP protocol are essential to
    any system with Bluetooth thus are always compiled in from now on.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Luis R. Rodriguez <mcgrof@frijolero.org>
config.mk
patches/08-rename-config-options.patch

index f09d16d48c6fec13ad85166cc7e91fa1b60a4d45..e44b814271de4391cc2b2579349717395f5783b4 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -211,8 +211,6 @@ CONFIG_LIB80211_CRYPT_TKIP=m
 # CONFIG_LIB80211_DEBUG=y
 
 CONFIG_BT=m
-CONFIG_COMPAT_BT_L2CAP=y
-CONFIG_COMPAT_BT_SCO=y
 CONFIG_BT_RFCOMM=m
 CONFIG_BT_RFCOMM_TTY=y
 CONFIG_BT_BNEP=m
index 2f732766619b54c4c60a3a7a89b869bcc763d129..249d47179c31230bd1e4e185f359a1da5073eac5 100644 (file)
@@ -61,40 +61,17 @@ CONFIG_BT_HIDP does not build with older kernel versions.
  
  zd1211rw-objs := zd_chip.o zd_mac.o \
                zd_rf_al2230.o zd_rf_rf2959.o \
---- a/include/net/bluetooth/bluetooth.h
-+++ b/include/net/bluetooth/bluetooth.h
-@@ -250,7 +250,7 @@ extern void bt_sysfs_cleanup(void);
- extern struct dentry *bt_debugfs;
--#ifdef CONFIG_BT_L2CAP
-+#ifdef CONFIG_COMPAT_BT_L2CAP
- int l2cap_init(void);
- void l2cap_exit(void);
- #else
-@@ -264,7 +264,7 @@ static inline void l2cap_exit(void)
- }
- #endif
--#ifdef CONFIG_BT_SCO
-+#ifdef CONFIG_COMPAT_BT_SCO
- int sco_init(void);
- void sco_exit(void);
- #else
 --- a/net/bluetooth/Makefile
 +++ b/net/bluetooth/Makefile
-@@ -6,8 +6,8 @@ obj-$(CONFIG_BT)       += bluetooth.o
+@@ -6,7 +6,7 @@ obj-$(CONFIG_BT)       += bluetooth.o
  obj-$(CONFIG_BT_RFCOMM)       += rfcomm/
  obj-$(CONFIG_BT_BNEP) += bnep/
  obj-$(CONFIG_BT_CMTP) += cmtp/
 -obj-$(CONFIG_BT_HIDP) += hidp/
 +obj-$(CONFIG_COMPAT_BT_HIDP)  += hidp/
  
- bluetooth-y := af_bluetooth.o hci_core.o hci_conn.o hci_event.o mgmt.o hci_sock.o hci_sysfs.o lib.o
--bluetooth-$(CONFIG_BT_L2CAP)  += l2cap_core.o l2cap_sock.o smp.o
--bluetooth-$(CONFIG_BT_SCO)    += sco.o
-+bluetooth-$(CONFIG_COMPAT_BT_L2CAP)   += l2cap_core.o l2cap_sock.o smp.o
-+bluetooth-$(CONFIG_COMPAT_BT_SCO)     += sco.o
+ bluetooth-y := af_bluetooth.o hci_core.o hci_conn.o hci_event.o mgmt.o \
+       hci_sock.o hci_sysfs.o l2cap_core.o l2cap_sock.o smp.o sco.o lib.o
 --- a/net/bluetooth/hidp/Makefile
 +++ b/net/bluetooth/hidp/Makefile
 @@ -2,6 +2,6 @@