petitboot: Use uname for hostname
authorGeoff Levand <geoffrey.levand@am.sony.com>
Fri, 22 Feb 2013 01:05:37 +0000 (01:05 +0000)
committerGeoff Levand <geoffrey.levand@am.sony.com>
Fri, 22 Feb 2013 01:05:37 +0000 (01:05 +0000)
Signed-off-by: Geoff Levand <geoff@infradead.org>
SVN-Revision: 35742

utils/petitboot/Makefile

index 4e072ea8e760d5aadd52683b5057761941e4c992..4ae52e89ff5c0eb06fc6b4f67505e6ffe9a97822 100644 (file)
@@ -72,7 +72,7 @@ petitboot-install-autorun-$(CONFIG_PETITBOOT_AUTORUN_GUI) = \
        ln -sf pb-twin $(1)/usr/sbin/petitboot
 
 CONFIGURE_ARGS += $(petitboot-config-args-y) \
-       PACKAGE_VERSION=$(shell echo ${HOSTNAME})-$(shell date +%y.%m.%d-%H.%M)
+       PACKAGE_VERSION=$(shell uname -n)-$(shell date +%y.%m.%d-%H.%M)
 
 EXTRA_CPPFLAGS += $(petitboot-cppflags-y)