projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
e71ae20
)
detect changes in package/kernel/modules/*.mk when scanning the package metadata
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 28 Mar 2007 18:06:33 +0000
(18:06 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 28 Mar 2007 18:06:33 +0000
(18:06 +0000)
SVN-Revision: 6746
include/scan.mk
patch
|
blob
|
history
diff --git
a/include/scan.mk
b/include/scan.mk
index ff23e0961ca24a53d51128b409f0ff46cfe77899..a7f74ecec8b637cfa46d8b3aed6d679497717984 100644
(file)
--- a/
include/scan.mk
+++ b/
include/scan.mk
@@
-32,6
+32,11
@@
$(SCAN_STAMP):
touch $@
endif
+# FIXME: generate this dynamically?
+ifeq ($(SCAN_TARGET),pkginfo)
+tmp/info/.pkginfo-kernel: $(shell ls package/kernel/modules/*.mk)
+endif
+
define scanfiles
$(foreach FILE,$(SCAN),
tmp/.$(SCAN_TARGET): tmp/info/.$(SCAN_TARGET)-$(FILE) FORCE