mt7621: netgear_ex6150: fix reboot loop by using LZMA loader
authorPetr Štetiar <ynezz@true.cz>
Tue, 18 Oct 2022 06:55:46 +0000 (08:55 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 18 Oct 2022 07:05:08 +0000 (09:05 +0200)
This fixes a well known "LZMA ERROR 1" error, reported previously on
numerous of similar devices.

Fixes: #10645
Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry picked from commit 7dd1cab1c16f374716b1ee7a5bf99f849b74c1dc)

target/linux/ramips/image/mt7621.mk

index a3bdacb32a1657c15cba29512466b34a97af2e9a..8a9f6d7b821a1349fa2e5367709eb0e15aada397 100644 (file)
@@ -1235,6 +1235,7 @@ TARGET_DEVICES += mts_wg430223
 
 define Device/netgear_ex6150
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   DEVICE_VENDOR := NETGEAR
   DEVICE_MODEL := EX6150
   DEVICE_PACKAGES := kmod-mt76x2