imx: fix cortexa9/cortexa7 image builds due to dts move
authorTim Harvey <tharvey@gateworks.com>
Mon, 20 May 2024 19:28:52 +0000 (12:28 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 6 Jun 2024 20:04:23 +0000 (22:04 +0200)
The IMX device-tree's for arm moved from arch/arm/boot/dts to
arch/arm/boot/dts/nxp/imx. Use that if using the 6.6 kernel.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
target/linux/imx/image/cortexa7.mk
target/linux/imx/image/cortexa9.mk

index d5a23fc6e9ed383a7ce99cce9f911e4e9a48c3f2..3f89a99a8390c53b0c5299b1b0fa201f6495d583 100644 (file)
@@ -10,6 +10,9 @@ define Device/Default
   KERNEL_NAME := zImage
   KERNEL := kernel-bin | uImage none
   KERNEL_LOADADDR := 0x80008000
+ifdef CONFIG_LINUX_6_6
+  DTS_DIR := $(DTS_DIR)/nxp/imx
+endif
   IMAGES :=
 endef
 
index 2321469cc861e8919a8a8d7880a3e3eabb5018ee..1ff5bcb8a7e442257533405fb81df1b0cc2c820c 100644 (file)
@@ -84,6 +84,9 @@ define Device/Default
   KERNEL_NAME := zImage
   KERNEL := kernel-bin | uImage none
   KERNEL_LOADADDR := 0x10008000
+ifdef CONFIG_LINUX_6_6
+  DTS_DIR := $(DTS_DIR)/nxp/imx
+endif
   IMAGES :=
 endef