netperf: update 2.3pl1 > 2.4.3 (#2180)
authorOliver Ertl <oliver@ertl-net.net>
Sat, 11 Aug 2007 15:46:14 +0000 (15:46 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Sat, 11 Aug 2007 15:46:14 +0000 (15:46 +0000)
SVN-Revision: 8397

net/netperf/Makefile
net/netperf/patches/001-netperf-2.3pl1-openwrt.patch [deleted file]

index 75766818cac4f376299e797ed5e3faf0970c594c..3b0fd01c1d41be025f90fe4498b19e53fc85c4b3 100644 (file)
@@ -9,16 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netperf
-PKG_VERSION:=2.3pl1
-PKG_RELEASE:=1
+PKG_VERSION:=2.4.3
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.netperf.org/netperf/archive/ \
-       ftp://ftp.cup.hp.com/dist/networking/benchmarks/netperf/
-PKG_MD5SUM:=b74314d78af31cb13516fb9a372d2e86
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=ftp://ftp.netperf.org/netperf/
+PKG_MD5SUM:=391a0d98954c72a6ad7f08b8a115e1ce
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,21 +25,22 @@ define Package/netperf
   URL:=http://www.netperf.org/
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               TARGET_NETPERF_HOME="/etc/netperf.conf" \
-               TARGET_CC="$(TARGET_CROSS)gcc" \
-               TARGET_CFLAGS="$(TARGET_CFLAGS)" \
-               TARGET_LIBS="" \
-               all
-endef
-
-define Package/netperf/install 
+define Package/netperf/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/netserver.init $(1)/etc/init.d/netserver
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/netperf $(1)/usr/bin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/netserver $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/netperf $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/netserver $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/lib/netperf
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/doc/examples/arr_script $(1)/lib/netperf
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/doc/examples/packet_byte_script $(1)/lib/netperf
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/doc/examples/sctp_stream_script $(1)/lib/netperf
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/doc/examples/snapshot_script $(1)/lib/netperf
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/doc/examples/tcp_range_script $(1)/lib/netperf
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/doc/examples/tcp_rr_script $(1)/lib/netperf
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/doc/examples/tcp_stream_script $(1)/lib/netperf
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/doc/examples/udp_rr_script $(1)/lib/netperf
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/doc/examples/udp_stream_script $(1)/lib/netperf
 endef
 
 $(eval $(call BuildPackage,netperf))
diff --git a/net/netperf/patches/001-netperf-2.3pl1-openwrt.patch b/net/netperf/patches/001-netperf-2.3pl1-openwrt.patch
deleted file mode 100644 (file)
index b83ca11..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
---- netperf-2.3pl1.orig/makefile       2004-09-21 23:33:40.000000000 +0200
-+++ netperf-2.3pl1/makefile    2005-12-30 15:35:08.924238576 +0100
-@@ -15,8 +15,7 @@
- # for the rest of the world, it is probably better to put the binaries
- # in /usr/local/netperf or /opt/netperf
- #
--#NETPERF_HOME = /usr/local/netperf
--NETPERF_HOME = /opt/netperf
-+NETPERF_HOME = $(TARGET_NETPERF_HOME)
- # The compiler on your system might be somewhere else, and/or have
- # a different name.
-@@ -40,7 +39,7 @@
- # You may safely ignore that warning.
- #
--CC = cc
-+CC = $(TARGET_CC)
- # Adding flags to CFLAGS enables some non-mainline features. For
- # more information, please consult the source code.
-@@ -113,7 +112,7 @@
- #                   netserver via the netperf command line with -T
- LOG_FILE=DEBUG_LOG_FILE="\"/tmp/netperf.debug\""
--CFLAGS = -O -D$(LOG_FILE) -DNEED_MAKEFILE_EDIT
-+CFLAGS = -D$(LOG_FILE) $(TARGET_CFLAGS)
- # Some platforms, and some options, require additional libraries.
- # you can add to the "LIBS =" line to accomplish this. if you find
-@@ -136,7 +135,7 @@
- # -lresolv              - required for -DDO_DNS on RedHat 7.1
- # -lsocket -lbind       - required for Zeta OS
--LIBS= -lm
-+LIBS= -lm $(TARGET_LIBS)
- # ---------------------------------------------------------------
- # it should not be the case that anything below this line needs to