projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b4d5132
)
kernel: video: add kmod-i2c-core dependency to kmod-drm
author
Rafał Miłecki
<rafal@milecki.pl>
Sun, 19 Mar 2017 19:26:34 +0000
(20:26 +0100)
committer
Rafał Miłecki
<rafal@milecki.pl>
Tue, 21 Mar 2017 06:24:19 +0000
(07:24 +0100)
For targets with i2c not built-in this fixes following error:
Package kmod-drm is missing dependencies for the following libraries:
i2c-core.ko
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
package/kernel/linux/modules/video.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/video.mk
b/package/kernel/linux/modules/video.mk
index 7baa77aa6bf0bdcc30d3276173c9508b2184564a..f70a5653c62bf781b19c7e69f47841dea78decd0 100644
(file)
--- a/
package/kernel/linux/modules/video.mk
+++ b/
package/kernel/linux/modules/video.mk
@@
-186,7
+186,7
@@
define KernelPackage/drm
SUBMENU:=$(VIDEO_MENU)
TITLE:=Direct Rendering Manager (DRM) support
HIDDEN:=1
- DEPENDS:=+kmod-dma-buf
+ DEPENDS:=+kmod-dma-buf
+kmod-i2c-core
KCONFIG:=CONFIG_DRM \
CONFIG_DRM_FBDEV_EMULATION=n \
CONFIG_DRM_LOAD_EDID_FIRMWARE=n \