projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
868d5f9
)
busybox: disable timestamp in version
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 28 Jan 2016 22:42:25 +0000
(22:42 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 28 Jan 2016 22:42:25 +0000
(22:42 +0000)
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
SVN-Revision: 48539
package/utils/busybox/Makefile
patch
|
blob
|
history
diff --git
a/package/utils/busybox/Makefile
b/package/utils/busybox/Makefile
index 5ca4363f1d258bd93adcfeb6cef84e733b7c881e..95e785bfe626a48b622f81030bb6454789f8ce0c 100644
(file)
--- a/
package/utils/busybox/Makefile
+++ b/
package/utils/busybox/Makefile
@@
-57,6
+57,9
@@
endef
BUSYBOX_SYM=$(if $(CONFIG_BUSYBOX_CUSTOM),CONFIG,DEFAULT)
+# don't create a version string containing the actual timestamp
+export KCONFIG_NOTIMESTAMP=1
+
define Build/Configure
rm -f $(PKG_BUILD_DIR)/.configured*
grep 'CONFIG_BUSYBOX_$(BUSYBOX_SYM)' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_$(BUSYBOX_SYM)_\\(.*\\),\\1CONFIG_\\2,g" > $(PKG_BUILD_DIR)/.config