flashrom: update to 0.9.3 and fix dependency
authorFlorian Fainelli <florian@openwrt.org>
Mon, 28 Mar 2011 21:30:30 +0000 (21:30 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 28 Mar 2011 21:30:30 +0000 (21:30 +0000)
Bump flashrom to current version, and reflect that it uses dmidecode as a helper.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
SVN-Revision: 26343

utils/flashrom/Makefile

index 698dc430740fca10edeb6a3dd18ff7789a806388..fd1cf8b86df4909884326740a3e775193aa66de9 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flashrom
-PKG_VERSION:=0.9.1
+PKG_VERSION:=0.9.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://qa.coreboot.org/releases/
-PKG_MD5SUM:=2b7cc0e45a0ac4c6d43c0f7cd05b041a
+PKG_MD5SUM:=eccdec2764223f5d2839bf577380eaa9
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,8 +23,8 @@ define Package/flashrom
   CATEGORY:=Utilities
   TITLE:=FlashROM Utility
   URL:=http://www.flashrom.org/
-# XXX: needs <sys/io.h>, only available on theese arch right now
-  DEPENDS:=+zlib +pciutils @(arm||armeb||i386||i686||x86_64)
+# XXX: needs <sys/io.h>, only available on these arch right now
+  DEPENDS:=+zlib +pciutils +dmidecode @(arm||armeb||i386||i686||x86_64)
 endef
 
 define Package/flashrom/description