PCI: hv: Add a Hyper-V PCI interface driver for software backchannel interface
authorHaiyang Zhang <haiyangz@microsoft.com>
Thu, 22 Aug 2019 05:05:41 +0000 (05:05 +0000)
committerDavid S. Miller <davem@davemloft.net>
Thu, 22 Aug 2019 07:25:12 +0000 (00:25 -0700)
This interface driver is a helper driver allows other drivers to
have a common interface with the Hyper-V PCI frontend driver.

Signed-off-by: Haiyang Zhang <haiyangz@microsoft.com>
Signed-off-by: Saeed Mahameed <saeedm@mellanox.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
MAINTAINERS
drivers/pci/Kconfig
drivers/pci/controller/Kconfig
drivers/pci/controller/Makefile
drivers/pci/controller/pci-hyperv-intf.c [new file with mode: 0644]
drivers/pci/controller/pci-hyperv.c
include/linux/hyperv.h

index a406947b369ebd1fe41866049691f6e7f65543e7..986085351d79869934a5df9140adbbed5c9d05f0 100644 (file)
@@ -7469,6 +7469,7 @@ F:        drivers/hid/hid-hyperv.c
 F:     drivers/hv/
 F:     drivers/input/serio/hyperv-keyboard.c
 F:     drivers/pci/controller/pci-hyperv.c
+F:     drivers/pci/controller/pci-hyperv-intf.c
 F:     drivers/net/hyperv/
 F:     drivers/scsi/storvsc_drv.c
 F:     drivers/uio/uio_hv_generic.c
index 2ab92409210afc0cc8cf54da3bef2392abd7d5c3..c313de96a3573071c199b9b86640e1f838105e7c 100644 (file)
@@ -182,6 +182,7 @@ config PCI_LABEL
 config PCI_HYPERV
         tristate "Hyper-V PCI Frontend"
         depends on X86 && HYPERV && PCI_MSI && PCI_MSI_IRQ_DOMAIN && X86_64
+       select PCI_HYPERV_INTERFACE
         help
           The PCI device frontend driver allows the kernel to import arbitrary
           PCI devices from a PCI backend to support PCI driver domains.
index fe9f9f13ce11ccce211dc1bcf8bb1d0512141ea4..70e078238899f206ab5885a103468453e8ac9dc4 100644 (file)
@@ -281,5 +281,12 @@ config VMD
          To compile this driver as a module, choose M here: the
          module will be called vmd.
 
+config PCI_HYPERV_INTERFACE
+       tristate "Hyper-V PCI Interface"
+       depends on X86 && HYPERV && PCI_MSI && PCI_MSI_IRQ_DOMAIN && X86_64
+       help
+         The Hyper-V PCI Interface is a helper driver allows other drivers to
+         have a common interface with the Hyper-V PCI frontend driver.
+
 source "drivers/pci/controller/dwc/Kconfig"
 endmenu
index d56a507495c5edd902a6012420924b9b837203a5..a2a22c9d91afc9662cdfb85607be68792f1adac1 100644 (file)
@@ -4,6 +4,7 @@ obj-$(CONFIG_PCIE_CADENCE_HOST) += pcie-cadence-host.o
 obj-$(CONFIG_PCIE_CADENCE_EP) += pcie-cadence-ep.o
 obj-$(CONFIG_PCI_FTPCI100) += pci-ftpci100.o
 obj-$(CONFIG_PCI_HYPERV) += pci-hyperv.o
+obj-$(CONFIG_PCI_HYPERV_INTERFACE) += pci-hyperv-intf.o
 obj-$(CONFIG_PCI_MVEBU) += pci-mvebu.o
 obj-$(CONFIG_PCI_AARDVARK) += pci-aardvark.o
 obj-$(CONFIG_PCI_TEGRA) += pci-tegra.o
diff --git a/drivers/pci/controller/pci-hyperv-intf.c b/drivers/pci/controller/pci-hyperv-intf.c
new file mode 100644 (file)
index 0000000..cc96be4
--- /dev/null
@@ -0,0 +1,67 @@
+// SPDX-License-Identifier: GPL-2.0
+/*
+ * Copyright (c) Microsoft Corporation.
+ *
+ * Author:
+ *   Haiyang Zhang <haiyangz@microsoft.com>
+ *
+ * This small module is a helper driver allows other drivers to
+ * have a common interface with the Hyper-V PCI frontend driver.
+ */
+
+#define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
+
+#include <linux/kernel.h>
+#include <linux/module.h>
+#include <linux/hyperv.h>
+
+struct hyperv_pci_block_ops hvpci_block_ops;
+EXPORT_SYMBOL_GPL(hvpci_block_ops);
+
+int hyperv_read_cfg_blk(struct pci_dev *dev, void *buf, unsigned int buf_len,
+                       unsigned int block_id, unsigned int *bytes_returned)
+{
+       if (!hvpci_block_ops.read_block)
+               return -EOPNOTSUPP;
+
+       return hvpci_block_ops.read_block(dev, buf, buf_len, block_id,
+                                         bytes_returned);
+}
+EXPORT_SYMBOL_GPL(hyperv_read_cfg_blk);
+
+int hyperv_write_cfg_blk(struct pci_dev *dev, void *buf, unsigned int len,
+                        unsigned int block_id)
+{
+       if (!hvpci_block_ops.write_block)
+               return -EOPNOTSUPP;
+
+       return hvpci_block_ops.write_block(dev, buf, len, block_id);
+}
+EXPORT_SYMBOL_GPL(hyperv_write_cfg_blk);
+
+int hyperv_reg_block_invalidate(struct pci_dev *dev, void *context,
+                               void (*block_invalidate)(void *context,
+                                                        u64 block_mask))
+{
+       if (!hvpci_block_ops.reg_blk_invalidate)
+               return -EOPNOTSUPP;
+
+       return hvpci_block_ops.reg_blk_invalidate(dev, context,
+                                                 block_invalidate);
+}
+EXPORT_SYMBOL_GPL(hyperv_reg_block_invalidate);
+
+static void __exit exit_hv_pci_intf(void)
+{
+}
+
+static int __init init_hv_pci_intf(void)
+{
+       return 0;
+}
+
+module_init(init_hv_pci_intf);
+module_exit(exit_hv_pci_intf);
+
+MODULE_DESCRIPTION("Hyper-V PCI Interface");
+MODULE_LICENSE("GPL v2");
index 57adeca7bda9a52c1f844796450f9beeb36d14f9..9c93ac2215b750dec6b8e811a983d279a0ad8b9b 100644 (file)
@@ -983,7 +983,6 @@ int hv_read_config_block(struct pci_dev *pdev, void *buf, unsigned int len,
        *bytes_returned = comp_pkt.bytes_returned;
        return 0;
 }
-EXPORT_SYMBOL(hv_read_config_block);
 
 /**
  * hv_pci_write_config_compl() - Invoked when a response packet for a write
@@ -1070,7 +1069,6 @@ int hv_write_config_block(struct pci_dev *pdev, void *buf, unsigned int len,
 
        return 0;
 }
-EXPORT_SYMBOL(hv_write_config_block);
 
 /**
  * hv_register_block_invalidate() - Invoked when a config block invalidation
@@ -1101,7 +1099,6 @@ int hv_register_block_invalidate(struct pci_dev *pdev, void *context,
        return 0;
 
 }
-EXPORT_SYMBOL(hv_register_block_invalidate);
 
 /* Interrupt management hooks */
 static void hv_int_desc_free(struct hv_pci_dev *hpdev,
@@ -3045,10 +3042,19 @@ static struct hv_driver hv_pci_drv = {
 static void __exit exit_hv_pci_drv(void)
 {
        vmbus_driver_unregister(&hv_pci_drv);
+
+       hvpci_block_ops.read_block = NULL;
+       hvpci_block_ops.write_block = NULL;
+       hvpci_block_ops.reg_blk_invalidate = NULL;
 }
 
 static int __init init_hv_pci_drv(void)
 {
+       /* Initialize PCI block r/w interface */
+       hvpci_block_ops.read_block = hv_read_config_block;
+       hvpci_block_ops.write_block = hv_write_config_block;
+       hvpci_block_ops.reg_blk_invalidate = hv_register_block_invalidate;
+
        return vmbus_driver_register(&hv_pci_drv);
 }
 
index 9d37f8cf1245afcf7cd91f68766e16af36d234f0..2afe6fdc1ddadc9e5b9b91bf75921d015d85f51c 100644 (file)
@@ -1579,18 +1579,32 @@ hv_pkt_iter_next(struct vmbus_channel *channel,
            pkt = hv_pkt_iter_next(channel, pkt))
 
 /*
- * Functions for passing data between SR-IOV PF and VF drivers.  The VF driver
+ * Interface for passing data between SR-IOV PF and VF drivers. The VF driver
  * sends requests to read and write blocks. Each block must be 128 bytes or
  * smaller. Optionally, the VF driver can register a callback function which
  * will be invoked when the host says that one or more of the first 64 block
  * IDs is "invalid" which means that the VF driver should reread them.
  */
 #define HV_CONFIG_BLOCK_SIZE_MAX 128
-int hv_read_config_block(struct pci_dev *dev, void *buf, unsigned int buf_len,
-                        unsigned int block_id, unsigned int *bytes_returned);
-int hv_write_config_block(struct pci_dev *dev, void *buf, unsigned int len,
-                         unsigned int block_id);
-int hv_register_block_invalidate(struct pci_dev *dev, void *context,
-                                void (*block_invalidate)(void *context,
-                                                         u64 block_mask));
+
+int hyperv_read_cfg_blk(struct pci_dev *dev, void *buf, unsigned int buf_len,
+                       unsigned int block_id, unsigned int *bytes_returned);
+int hyperv_write_cfg_blk(struct pci_dev *dev, void *buf, unsigned int len,
+                        unsigned int block_id);
+int hyperv_reg_block_invalidate(struct pci_dev *dev, void *context,
+                               void (*block_invalidate)(void *context,
+                                                        u64 block_mask));
+
+struct hyperv_pci_block_ops {
+       int (*read_block)(struct pci_dev *dev, void *buf, unsigned int buf_len,
+                         unsigned int block_id, unsigned int *bytes_returned);
+       int (*write_block)(struct pci_dev *dev, void *buf, unsigned int len,
+                          unsigned int block_id);
+       int (*reg_blk_invalidate)(struct pci_dev *dev, void *context,
+                                 void (*block_invalidate)(void *context,
+                                                          u64 block_mask));
+};
+
+extern struct hyperv_pci_block_ops hvpci_block_ops;
+
 #endif /* _HYPERV_H */